summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commitf199057b8679cd2eed424fccb45361c89a133d31 (patch)
treee6ec41e59db82809cd99452c53c9efe67a3985e3 /games-action/d2x
parentgames action and arcade (diff)
downloadgentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.gz
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.bz2
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.zip
action games !
Diffstat (limited to 'games-action/d2x')
-rw-r--r--games-action/d2x/ChangeLog8
-rw-r--r--games-action/d2x/Manifest4
-rw-r--r--games-action/d2x/d2x-0.2.5.ebuild68
-rw-r--r--games-action/d2x/files/0.2.5-shellscripts.patch22
-rw-r--r--games-action/d2x/files/digest-d2x-0.2.52
5 files changed, 104 insertions, 0 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
new file mode 100644
index 000000000000..68d971c06616
--- /dev/null
+++ b/games-action/d2x/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/d2x
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+*d2x-0.2.5 (19 Jul 2003)
+
+ 19 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Rob Cakebread <robc@myrealbox.com> #24843.
diff --git a/games-action/d2x/Manifest b/games-action/d2x/Manifest
new file mode 100644
index 000000000000..7dc23749a49b
--- /dev/null
+++ b/games-action/d2x/Manifest
@@ -0,0 +1,4 @@
+MD5 b1808ecc3bf31d671736a2a40a12fb90 d2x-0.2.5.ebuild 1910
+MD5 b298d324cbce31e8cc4779c765fabc4d files/digest-d2x-0.2.5 123
+MD5 499b24f4949333a0c04d1177aa3213e5 files/0.2.5-shellscripts.patch 747
+MD5 8ed44ee6825fbacc39bd3cd0fe2f0975 ChangeLog 368
diff --git a/games-action/d2x/d2x-0.2.5.ebuild b/games-action/d2x/d2x-0.2.5.ebuild
new file mode 100644
index 000000000000..5f71d1d53abe
--- /dev/null
+++ b/games-action/d2x/d2x-0.2.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games flag-o-matic eutils
+
+DATAFILE=d2shar10
+DESCRIPTION="Descent 2"
+HOMEPAGE="http://icculus.org/d2x/"
+SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz
+ http://icculus.org/d2x/data/${DATAFILE}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="debug opengl ggi svga"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ opengl? ( virtual/opengl )
+ ggi? ( media-libs/libggi )
+ svga? ( media-libs/svgalib )
+ x86? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${DATAFILE}
+ rm *.{exe,bat}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-shellscripts.patch
+}
+
+src_compile() {
+ # --disable-network --enable-console
+ local myconf="`use_enable x86 assembler`"
+ [ `use debug` ] \
+ && debugconf="${myconf} --enable-debug --disable-release" \
+ || debugconf="${myconf} --disable-debug --enable-release"
+ # we do this because each of the optional guys define the same functions
+ # in gr, thus when they go to link they cause redefine errors ...
+ # we build each by it self, save the binary file, clean up, and start over
+ mkdir my-bins
+ for ren in sdl `use opengl` `use svga` `use ggi` ; do
+ [ "${ren}" == "sdl" ] \
+ && renconf="" \
+ || renconf="--with-${ren}"
+ [ "${ren}" == "svga" ] \
+ && defflags="-DSVGALIB_INPUT" \
+ || defflags=""
+ make distclean
+ egamesconf \
+ ${myconf} \
+ ${renconf} \
+ --datadir=${GAMES_DATADIR_BASE} \
+ || die "conf ${ren}"
+ emake CXXFLAGS="${CXXFLAGS} ${defflags}" || die "build ${ren}"
+ mv d2x* my-bins/
+ done
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dogamesbin my-bins/*
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -r ${WORKDIR}/${DATAFILE}/* ${D}/${GAMES_DATADIR}/${PN}/
+ dodoc AUTHORS ChangeLog NEWS README* TODO readme.txt
+ prepgamesdirs
+}
diff --git a/games-action/d2x/files/0.2.5-shellscripts.patch b/games-action/d2x/files/0.2.5-shellscripts.patch
new file mode 100644
index 000000000000..bd1ca7c7f845
--- /dev/null
+++ b/games-action/d2x/files/0.2.5-shellscripts.patch
@@ -0,0 +1,22 @@
+--- d2x-gl.sh.orig 2003-07-19 22:04:48.000000000 -0400
++++ d2x-gl.sh 2003-07-19 22:05:25.000000000 -0400
+@@ -35,8 +35,7 @@
+ # Finally, run the real game.
+ # All switches can be overwritten by command-line arguments.
+ #
+-nice /usr/games/d2x-gl.real -tmap fp -nocdrom -nomovies \
++exec nice d2x-gl -tmap fp -nocdrom -nomovies \
+ -gl_mipmap -gl_alttexmerge -gl_reticle 2 \
+ -nofades \
+- $1 $2 $3 $4 $5
+-
++ ${@}
+--- d2x-sdl.sh.orig 2003-07-19 22:05:04.000000000 -0400
++++ d2x-sdl.sh 2003-07-19 22:05:39.000000000 -0400
+@@ -3,5 +3,5 @@
+ # Run the real game.
+ # All switches can be overwritten by command-line arguments.
+ #
+-nice /usr/games/d2x-sdl.real -nocdrom -nomovies -nofades $1 $2 $3 $4 $5
++exec nice d2x-sdl -nocdrom -nomovies -nofades ${@}
+
diff --git a/games-action/d2x/files/digest-d2x-0.2.5 b/games-action/d2x/files/digest-d2x-0.2.5
new file mode 100644
index 000000000000..3bae26d927d8
--- /dev/null
+++ b/games-action/d2x/files/digest-d2x-0.2.5
@@ -0,0 +1,2 @@
+MD5 79474db1ff4f0ae1fb76d691701cc560 d2x-0.2.5.tar.gz 2015249
+MD5 1b952cc4a4419e24d230589027d73490 d2shar10.tar.gz 4311406