summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-07-30 18:18:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-07-30 18:18:39 +0000
commit45a80e340af01ba3048aecb63ab54f18c68bef90 (patch)
treeff29c644fa79e50ec98b507fb16b55678d68a117 /games-action/d2x/d2x-0.2.5-r3.ebuild
parentVersion bump for bug 169785, thanks to Hendrik Iben for reporting. (diff)
downloadgentoo-2-45a80e340af01ba3048aecb63ab54f18c68bef90.tar.gz
gentoo-2-45a80e340af01ba3048aecb63ab54f18c68bef90.tar.bz2
gentoo-2-45a80e340af01ba3048aecb63ab54f18c68bef90.zip
some nasm vs yasm sed patches
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-action/d2x/d2x-0.2.5-r3.ebuild')
-rw-r--r--games-action/d2x/d2x-0.2.5-r3.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/games-action/d2x/d2x-0.2.5-r3.ebuild b/games-action/d2x/d2x-0.2.5-r3.ebuild
index 0824cc734fa1..c39f78dba847 100644
--- a/games-action/d2x/d2x-0.2.5-r3.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.4 2007/07/27 21:01:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.5 2007/07/30 18:18:39 mr_bones_ Exp $
inherit eutils flag-o-matic games
@@ -32,6 +32,16 @@ src_unpack() {
epatch "${FILESDIR}/${PV}-shellscripts.patch"
epatch "${FILESDIR}/${P}-dofpcalcs-macro.patch"
+
+ sed -i \
+ -e '/NASMFLAGS/s/-d/-D/g' \
+ configure \
+ 2d/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e 's/@@/l@@/' \
+ 2d/tmerge_a.asm \
+ || die "sed failed"
}
src_compile() {