summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-17 18:23:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-17 18:23:30 +0000
commit229777f19dca19e94732176d2f6fe39d8ada5af7 (patch)
tree44e67e3827d4110a9f7e02820b58d88dd6ef55e0 /games-action/d1x
parentMarking 0.9.13 stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-229777f19dca19e94732176d2f6fe39d8ada5af7.tar.gz
gentoo-2-229777f19dca19e94732176d2f6fe39d8ada5af7.tar.bz2
gentoo-2-229777f19dca19e94732176d2f6fe39d8ada5af7.zip
moved from games-fps (bug #41779)
Diffstat (limited to 'games-action/d1x')
-rw-r--r--games-action/d1x/ChangeLog10
-rw-r--r--games-action/d1x/Manifest6
-rw-r--r--games-action/d1x/d1x-20040118.ebuild139
-rw-r--r--games-action/d1x/files/d1x-makefile-linux.patch42
-rw-r--r--games-action/d1x/files/d1x-missiondir.patch27
-rw-r--r--games-action/d1x/files/digest-d1x-200401182
-rw-r--r--games-action/d1x/metadata.xml12
7 files changed, 238 insertions, 0 deletions
diff --git a/games-action/d1x/ChangeLog b/games-action/d1x/ChangeLog
new file mode 100644
index 000000000000..1aa1ec56b994
--- /dev/null
+++ b/games-action/d1x/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/d1x
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/ChangeLog,v 1.1 2004/02/17 18:22:33 mr_bones_ Exp $
+
+*d1x-20040118 (19 Jan 2004)
+
+ 19 Jan 2004; Jeremy Maitin-Shepard <jbms@gentoo.org> d1x-20040118.ebuild,
+ metadata.xml, files/d1x-makefile-linux.patch, files/d1x-missiondir.patch:
+ Initial import.
+
diff --git a/games-action/d1x/Manifest b/games-action/d1x/Manifest
new file mode 100644
index 000000000000..44d39d1976b1
--- /dev/null
+++ b/games-action/d1x/Manifest
@@ -0,0 +1,6 @@
+MD5 203a18187bcba9679a5b3102853fe7f4 files/digest-d1x-20040118 135
+MD5 fe21a7e67ef24de5864a502206052663 files/d1x-missiondir.patch 754
+MD5 951de74e67288963ee03c3719074f3fb files/d1x-makefile-linux.patch 1074
+MD5 e934dcba88bcd6ebfda040d966b5cb65 ChangeLog 406
+MD5 59f9d079172d0164a366133f9ef2ae34 metadata.xml 551
+MD5 5636bcd8202e648cef5731c5a704b1d3 d1x-20040118.ebuild 3321
diff --git a/games-action/d1x/d1x-20040118.ebuild b/games-action/d1x/d1x-20040118.ebuild
new file mode 100644
index 000000000000..251e2eed1766
--- /dev/null
+++ b/games-action/d1x/d1x-20040118.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/d1x-20040118.ebuild,v 1.1 2004/02/17 18:22:34 mr_bones_ Exp $
+
+inherit games eutils
+
+DESCRIPTION="Descent 1 Source Project"
+HOMEPAGE="http://d1x.warpcore.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2 mirror://gentoo/descent1.5-patch.tar.bz2"
+
+LICENSE="Descent1 D1X"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="opengl"
+
+DEPEND=">=dev-lang/nasm-0.97
+ media-libs/libsdl
+ opengl? (
+ virtual/opengl
+ media-libs/libpng
+ sys-libs/zlib
+ )"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup () {
+ cdrom_get_cds descent
+ games_pkg_setup
+}
+
+src_unpack () {
+ unpack ${A}
+
+ local dir="${WORKDIR}/descent1-data"
+ mkdir "${dir}" || die
+
+ # Copy data files
+ local src="${CDROM_ROOT}/descent"
+ cd "${src}" || die
+
+ for x in chaos.hog chaos.msn descent.b50 descent.dem descent.hog \
+ descent.m50 descent.phx descent.pig descent2.adv descentg.ini \
+ level18.dem miniboss.dem readme.txt descent.faq orderfrm.txt \
+ devteam.pcx; do
+ cp "${x}" "${dir}" || die
+ done
+
+ # Apply 1.0 -> 1.5 patch
+ cd "${WORKDIR}/descent1.5-patch" || die
+ for x in *.patch; do
+ if patch "${dir}/${x%%.patch}" < "${x}" \
+ >/dev/null 2>/dev/null; then
+ einfo "Patched ${x%%.patch} to version 1.5"
+ fi
+ done
+
+ cd "${S}" || die
+ epatch "${FILESDIR}/d1x-missiondir.patch" || die
+
+ cp defines.in defines.mak || die
+ epatch "${FILESDIR}/d1x-makefile-linux.patch" || die
+
+ if use opengl; then
+ sed -i -e 's/^#\(SDLGL_IO = 1\)/\1/' defines.mak || die
+ else
+ sed -i -e 's/^#\(SDL_IO = 1\)/\1/' defines.mak || die
+ fi
+}
+
+src_compile () {
+ make dep || die
+ make || die
+}
+
+src_install() {
+ # Install D1X documentation
+ cd "${S}"
+ dodoc d1x.faq d1x.txt d1x140.txt readme.d1x readme.org todo.txt \
+ bugs.txt || die
+ dodir
+
+ # Copy data files
+ local src="${WORKDIR}/descent1-data"
+ local dir="${GAMES_DATADIR}/d1x"
+ cd "${src}" || die
+
+ dodir "${dir}"
+
+ insinto "${dir}"
+ for x in chaos.hog chaos.msn descent.b50 descent.dem descent.hog \
+ descent.m50 descent.phx descent.pig descent2.adv descentg.ini \
+ level18.dem miniboss.dem; do
+ doins "${x}" || die
+ done
+
+ # Install original documentation files
+ dodoc "readme.txt" "descent.faq" "orderfrm.txt" "devteam.pcx" || die
+
+ # Copy d1x.ini
+ cd "${S}" || die
+ insinto "${dir}"
+ doins d1x.ini || die
+
+ # Install the binary executable
+ local binname
+ if use opengl; then
+ binname="d1x143_ogl"
+ else
+ binname="d1x143"
+ fi
+
+ insinto "${GAMES_LIBDIR}/${PN}"
+ insopts -m0750
+ doins "${binname}"
+
+ # Install the shell script wrapper
+ local tempbin
+ tempbin="${T}/d1x"
+ echo -en "#!/bin/sh\n" > "${tempbin}"
+ echo -en "if [ ! -e \"\${HOME}/.d1x\" ]; then\n" >> "${tempbin}"
+ echo -en " mkdir \"\${HOME}/.d1x\"\n" >> "${tempbin}"
+ echo -en " cp \"${dir}/d1x.ini\" \"\${HOME}/.d1x/\"\n" >> "${tempbin}"
+ echo -en "fi\n\n" >> "${tempbin}"
+ echo -en "cd \"\${HOME}/.d1x/\"\n" >> "${tempbin}"
+ echo -en "exec ${GAMES_LIBDIR}/${PN}/${binname} " >> "${tempbin}"
+ echo -en "-missiondir \"${dir}\" \"\$@\"\n" >> "${tempbin}"
+ dogamesbin "${tempbin}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "You may want to install the additional map package, which contains"
+ einfo "popular third-party multiplayer maps."
+ echo
+ einfo "To do so, run: emerge games-fps/descent1-maps"
+}
diff --git a/games-action/d1x/files/d1x-makefile-linux.patch b/games-action/d1x/files/d1x-makefile-linux.patch
new file mode 100644
index 000000000000..21ebedd84485
--- /dev/null
+++ b/games-action/d1x/files/d1x-makefile-linux.patch
@@ -0,0 +1,42 @@
+--- defines.mak.orig 2004-01-18 22:48:53.176558208 -0500
++++ defines.mak 2004-01-18 22:56:45.215797336 -0500
+@@ -1,5 +1,5 @@
+ # NOERROR: make sure there are no warnings in compile
+-NOERROR = 1
++#NOERROR = 1
+
+ # NO_ASM: don't use assembler
+ #NO_ASM = 1
+@@ -38,12 +38,12 @@
+ RELEASE = 1
+
+ # environment
+-ENV_DJGPP = 1
++#ENV_DJGPP = 1
+ #ENV_DJGPP_REALDOS =1
+ #ENV_MINGW32 = 1
+ #ENV_CYGWIN = 1
+ #ENV_MSVC = 1
+-#ENV_LINUX = 1
++ENV_LINUX = 1
+
+ # if compiling with Cygwin, you need extra mingw compatible c++ libraries (see compile.txt)
+ #MINGW_EXTRA = /Cygnus/mingw/
+@@ -79,7 +79,7 @@
+ #GLX_IO = 1
+
+ # linux audio options (choose one)
+-#SDL_AUDIO = 1
++SDL_AUDIO = 1
+ #ALSA_AUDIO = 1
+
+ # secondary compiler options
+@@ -93,7 +93,7 @@
+ #sound options for dos: choose which
+ #MIKMOD = 1 #MikMod digital, can be used with allg_midi
+ #ALLG_MIDI = 1 #Allegro midi, can be used with mikmod
+-ALLEGRO = 1 #Allegro for midi and digi, should be used alone
++#ALLEGRO = 1 #Allegro for midi and digi, should be used alone
+
+ #music options for linux:
+ #HMIPLAY = 1
diff --git a/games-action/d1x/files/d1x-missiondir.patch b/games-action/d1x/files/d1x-missiondir.patch
new file mode 100644
index 000000000000..ace675cb6d9f
--- /dev/null
+++ b/games-action/d1x/files/d1x-missiondir.patch
@@ -0,0 +1,27 @@
+diff -ur d1x.orig/main/inferno.c d1x/main/inferno.c
+--- d1x.orig/main/inferno.c 2003-11-18 23:31:29.000000000 -0500
++++ d1x/main/inferno.c 2004-01-18 22:48:53.122566416 -0500
+@@ -1144,6 +1144,11 @@
+ // Things to initialize before anything else
+ arch_init_start();
+
++ if ((t = FindArg( "-missiondir" )))
++ cfile_use_alternate_hogdir(Args[t+1]);
++ else
++ cfile_use_alternate_hogdir("");
++
+ load_text();
+
+ // set_exit_message("\n\n%s", TXT_THANKS);
+@@ -1172,11 +1177,6 @@
+ }
+ //end this section addition - VR
+
+- if ((t = FindArg( "-missiondir" )))
+- cfile_use_alternate_hogdir(Args[t+1]);
+- else
+- cfile_use_alternate_hogdir("");
+-
+ if ((t=FindArg("-tmap"))){
+ select_tmap(Args[t+1]);
+ }else
diff --git a/games-action/d1x/files/digest-d1x-20040118 b/games-action/d1x/files/digest-d1x-20040118
new file mode 100644
index 000000000000..46832e95a0cb
--- /dev/null
+++ b/games-action/d1x/files/digest-d1x-20040118
@@ -0,0 +1,2 @@
+MD5 882b249c0b5c6bf0f0a830cba2c0234d d1x-20040118.tar.bz2 1372821
+MD5 f761763c7b3b0e0597db84dfdf4496ac descent1.5-patch.tar.bz2 193041
diff --git a/games-action/d1x/metadata.xml b/games-action/d1x/metadata.xml
new file mode 100644
index 000000000000..02d50bdd2acd
--- /dev/null
+++ b/games-action/d1x/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>d1x</herd>
+<maintainer>
+ <email>jbms@gentoo.org</email>
+ <name>Jeremy Maitin-Shepard</name>
+</maintainer>
+<longdescription>
+Descent 1 is a classic first-person shooter released in 1995 by Interplay and Parallax. It was one of the first games with true 3-dimensional graphics, movement, and light sourcing. D1X is a modification of the Descent 1 source that was released by Parallax.
+</longdescription>
+</pkgmetadata>