summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-08 00:15:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-08 00:15:28 +0000
commitc02179680d7d07122e3e907ff93091a39f61f429 (patch)
treeb1bf7327e28264be9aeb7775aff49044103f7db9 /games-action/cylindrix
parentonly pass --with-pkgversion with gcc-4.3+ as older versions of gcc have broke... (diff)
downloadgentoo-2-c02179680d7d07122e3e907ff93091a39f61f429.tar.gz
gentoo-2-c02179680d7d07122e3e907ff93091a39f61f429.tar.bz2
gentoo-2-c02179680d7d07122e3e907ff93091a39f61f429.zip
link fix (bug #216632)
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/cylindrix')
-rw-r--r--games-action/cylindrix/ChangeLog7
-rw-r--r--games-action/cylindrix/cylindrix-1.0.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/games-action/cylindrix/ChangeLog b/games-action/cylindrix/ChangeLog
index 69b72e8d3b2e..18d09d422532 100644
--- a/games-action/cylindrix/ChangeLog
+++ b/games-action/cylindrix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/cylindrix
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/ChangeLog,v 1.5 2007/04/16 05:01:58 mr_bones_ Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/ChangeLog,v 1.6 2008/04/08 00:15:28 mr_bones_ Exp $
+
+ 08 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org> cylindrix-1.0.ebuild:
+ link fix (bug #216632)
16 Apr 2007; Michael Sterrett <mr_bones_@gentoo.org> cylindrix-1.0.ebuild:
eautoreconf to find install (bug #174715); tidy
diff --git a/games-action/cylindrix/cylindrix-1.0.ebuild b/games-action/cylindrix/cylindrix-1.0.ebuild
index f5f531b25982..44b0f45add12 100644
--- a/games-action/cylindrix/cylindrix-1.0.ebuild
+++ b/games-action/cylindrix/cylindrix-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/cylindrix-1.0.ebuild,v 1.5 2007/04/16 05:01:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/cylindrix/cylindrix-1.0.ebuild,v 1.6 2008/04/08 00:15:28 mr_bones_ Exp $
inherit autotools games
@@ -28,6 +28,11 @@ src_unpack() {
eautoreconf
}
+src_compile() {
+ egamesconf || die
+ emake LDADD="$(allegro-config --libs)" || die "emake failed"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake failed"
insinto "${GAMES_DATADIR}"/${PN}