summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-11-15 23:54:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-11-15 23:54:37 +0000
commit53872a052ee285809eaa073c93d312295a124be5 (patch)
tree3c5f5105da1115cb12dba9dd387981c8e9401782 /games-action/bzflag
parentamd64 stable, bug 196616 (diff)
downloadgentoo-2-53872a052ee285809eaa073c93d312295a124be5.tar.gz
gentoo-2-53872a052ee285809eaa073c93d312295a124be5.tar.bz2
gentoo-2-53872a052ee285809eaa073c93d312295a124be5.zip
Version bump to 2.0.10
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-action/bzflag')
-rw-r--r--games-action/bzflag/ChangeLog7
-rw-r--r--games-action/bzflag/bzflag-2.0.10.ebuild70
-rw-r--r--games-action/bzflag/files/digest-bzflag-2.0.103
3 files changed, 79 insertions, 1 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index d67e065f9fc2..d2890c9910d3 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/bzflag
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.31 2007/05/31 02:12:58 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.32 2007/11/15 23:54:37 tupone Exp $
+
+*bzflag-2.0.10 (15 Nov 2007)
+
+ 15 Nov 2007; Tupone Alfredo <tupone@gentoo.org> +bzflag-2.0.10.ebuild:
+ Version bump
31 May 2007; Daniel Gryniewicz <dang@gentoo.org> bzflag-2.0.8.ebuild:
Marked stable on amd64 for bug #177087
diff --git a/games-action/bzflag/bzflag-2.0.10.ebuild b/games-action/bzflag/bzflag-2.0.10.ebuild
new file mode 100644
index 000000000000..228575f1da5f
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.0.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.10.ebuild,v 1.1 2007/11/15 23:54:37 tupone Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated sdl"
+
+UIDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/glew
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+
+DEPEND=">=net-misc/curl-7.15.0
+ sys-libs/ncurses
+ net-dns/c-ares
+ sdl? ( ${UIDEPEND} )
+ !sdl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+pkg_setup() {
+ # Only do the libsdl checks for !dedicated - bug #107792
+ use dedicated || GAMES_USE_SDL="nojoystick"
+ games_pkg_setup
+}
+
+src_compile() {
+ local myconf
+
+ if use dedicated && ! use sdl ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-regex \
+ ${myconf} \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS TODO ChangeLog BUGS PORTING DEVINFO NEWS README* RELNOTES
+
+ if use sdl || ! use dedicated ; then
+ doicon "data/bzflag-48x48.png"
+ make_desktop_entry ${PN} "BZFlag" ${PN}-48x48.png
+ fi
+
+ prepgamesdirs
+}
diff --git a/games-action/bzflag/files/digest-bzflag-2.0.10 b/games-action/bzflag/files/digest-bzflag-2.0.10
new file mode 100644
index 000000000000..bddbf9fcc928
--- /dev/null
+++ b/games-action/bzflag/files/digest-bzflag-2.0.10
@@ -0,0 +1,3 @@
+MD5 57b21beecaef146bf63c0f29179a9efe bzflag-2.0.10.tar.bz2 11438567
+RMD160 a013fc172be17dc4e9273495517dcb7e278cab41 bzflag-2.0.10.tar.bz2 11438567
+SHA256 adc3608055f6d4b0999f8e318f131cfe34bee89379e0914fd9017277c7536724 bzflag-2.0.10.tar.bz2 11438567