summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-09-14 07:48:38 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-09-14 07:48:38 +0000
commit2f999425eac796f1f634d4fca9d28cae3d9bde59 (patch)
tree027a99ce4d11dc1d3c489738d51b894306a49609 /games-action/bzflag
parentVersion bump. Drop qatomic-x32 patch applied upstream. Drop qpa useflag. (diff)
downloadgentoo-2-2f999425eac796f1f634d4fca9d28cae3d9bde59.tar.gz
gentoo-2-2f999425eac796f1f634d4fca9d28cae3d9bde59.tar.bz2
gentoo-2-2f999425eac796f1f634d4fca9d28cae3d9bde59.zip
Version bump to 2.4.2
(Portage version: 2.1.11.16/cvs/Linux i686)
Diffstat (limited to 'games-action/bzflag')
-rw-r--r--games-action/bzflag/ChangeLog7
-rw-r--r--games-action/bzflag/bzflag-2.4.2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index 6a6e088b70e0..9314d55e667e 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/bzflag
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.56 2012/01/10 20:34:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.57 2012/09/14 07:48:37 tupone Exp $
+
+*bzflag-2.4.2 (14 Sep 2012)
+
+ 14 Sep 2012; Tupone Alfredo <tupone@gentoo.org> +bzflag-2.4.2.ebuild:
+ Version bump to 2.4.2
10 Jan 2012; Brent Baude <ranger@gentoo.org> bzflag-2.4.0.ebuild:
Marking bzflag-2.4.0 ppc for bug 377575
diff --git a/games-action/bzflag/bzflag-2.4.2.ebuild b/games-action/bzflag/bzflag-2.4.2.ebuild
new file mode 100644
index 000000000000..94a163019376
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.4.2.ebuild,v 1.1 2012/09/14 07:48:38 tupone Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated sdl upnp"
+
+UIDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[audio,joystick,video]
+ media-libs/glew
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+
+DEPEND=">=net-misc/curl-7.15.0
+ sys-libs/ncurses
+ net-dns/c-ares
+ upnp? ( net-libs/miniupnpc )
+ sdl? ( ${UIDEPEND} )
+ !sdl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+src_configure() {
+ local myconf
+
+ if use dedicated && ! use sdl ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+ egamesconf \
+ --disable-ccachetest \
+ --disable-dependency-tracking \
+ --without-regex \
+ $(use_enable upnp UPnP) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS TODO ChangeLog BUGS PORTING DEVINFO NEWS README*
+
+ if use sdl || ! use dedicated ; then
+ newicon "data/bzflag-48x48.png" ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ prepgamesdirs
+}