summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-31 04:39:48 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-31 04:39:48 +0000
commitcc2bf64b7ad5c9eccac3427e55952d0ec0042cbe (patch)
treee314432607622e6eec31f0a8e17554f2b1688c9f /games-action/armagetronad
parentAdded ~sparc keyword wrt bug #152265. (diff)
downloadgentoo-2-cc2bf64b7ad5c9eccac3427e55952d0ec0042cbe.tar.gz
gentoo-2-cc2bf64b7ad5c9eccac3427e55952d0ec0042cbe.tar.bz2
gentoo-2-cc2bf64b7ad5c9eccac3427e55952d0ec0042cbe.zip
always copy/sed script regardless of USE
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'games-action/armagetronad')
-rw-r--r--games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild b/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
index 6017e33d1e68..a5dc3c1dd578 100644
--- a/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
+++ b/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild,v 1.4 2006/10/30 03:38:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild,v 1.5 2006/10/31 04:39:48 vapier Exp $
inherit eutils games
@@ -35,14 +35,12 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc4.patch
epatch "${FILESDIR}"/${P}-security-1.patch
- if use dedicated ; then
- cp "${FILESDIR}"/${PN}-ded "${FILESDIR}"/${PN} . || die
- sed -i \
- -e "s:@GAMES_SYSCONFDIR@:${GAMES_SYSCONFDIR}:" \
- -e "s:@GAMES_LIBDIR@:${GAMES_LIBDIR}:" \
- -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}:" \
- ${PN}-ded ${PN}
- fi
+ cp "${FILESDIR}"/${PN}-ded "${FILESDIR}"/${PN} . || die
+ sed -i \
+ -e "s:@GAMES_SYSCONFDIR@:${GAMES_SYSCONFDIR}:" \
+ -e "s:@GAMES_LIBDIR@:${GAMES_LIBDIR}:" \
+ -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}:" \
+ ${PN}-ded ${PN}
}
src_compile() {