summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-14 16:46:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-14 16:46:55 +0000
commit230eaffad27c5982ecf3b642a19526bcb1a43c07 (patch)
treea6b6baee2652aa5a33f14ecda0f3d213d4e8d72a /games-action/abuse/abuse-0.7.1.ebuild
parentStable on ppc wrt bug 234684 (diff)
downloadgentoo-2-230eaffad27c5982ecf3b642a19526bcb1a43c07.tar.gz
gentoo-2-230eaffad27c5982ecf3b642a19526bcb1a43c07.tar.bz2
gentoo-2-230eaffad27c5982ecf3b642a19526bcb1a43c07.zip
fix bug #231822 with sed patch from Tomáš Chvátal
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/abuse/abuse-0.7.1.ebuild')
-rw-r--r--games-action/abuse/abuse-0.7.1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/games-action/abuse/abuse-0.7.1.ebuild b/games-action/abuse/abuse-0.7.1.ebuild
index fabc689d9d0a..cb1d7ccf72ce 100644
--- a/games-action/abuse/abuse-0.7.1.ebuild
+++ b/games-action/abuse/abuse-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/abuse-0.7.1.ebuild,v 1.6 2008/04/11 15:46:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/abuse-0.7.1.ebuild,v 1.7 2008/08/14 16:46:55 mr_bones_ Exp $
inherit eutils games
@@ -25,12 +25,16 @@ DEPEND="${RDEPEND}
virtual/opengl"
src_unpack() {
unpack ${A}
- #fix placing additional patches
+ # fix placing additional patches
cp -rf "${WORKDIR}"/abuse-frabs-2.11/{addon,art,levels,lisp,music,netlevel,register} "${WORKDIR}"
cp -rf "${WORKDIR}"/abuse-lib-2.00.orig/unpacked/{addon,art,levels,lisp,abuse.lsp} "${WORKDIR}"
cp -rf "${WORKDIR}"/abuse-sfx-2.00.orig/sfx "${WORKDIR}"
rm -rf "${WORKDIR}"/abuse-frabs-2.11/ "${WORKDIR}"/abuse-lib-2.00.orig/ "${WORKDIR}"/abuse-sfx-2.00.orig/
- cd ${S}
+ cd "${S}"
+ # fix bug #231822
+ sed -i \
+ -e "s:/var/games/abuse:${GAMES_DATADIR}/${PN}:" \
+ src/sdlport/setup.cpp || or die "sed setup.cpp failed"
}
src_compile() {
@@ -45,13 +49,13 @@ src_install() {
dodoc AUTHORS ChangeLog README TODO
# Data install
- insinto "${GAMES_DATADIR}"/abuse
+ insinto "${GAMES_DATADIR}"/"${PN}"
doins -r "${WORKDIR}"/{addon,art,levels,lisp,music,netlevel,register,sfx} \
"${WORKDIR}"/abuse.lsp \
|| die "doins failed"
# Icons/desktop entry
- doicon abuse.png
+ doicon ${PN}.png
make_desktop_entry abuse "Abuse" ${PN}
prepgamesdirs