summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-12-09 05:02:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-12-09 05:02:59 +0000
commitf99b135f8ce653bb458d948e4b15f8ae8567088a (patch)
tree367e62bc7dad7b78def5b2831446d1d505f4cede /eclass
parentremoved ancient versions (diff)
downloadgentoo-2-f99b135f8ce653bb458d948e4b15f8ae8567088a.tar.gz
gentoo-2-f99b135f8ce653bb458d948e4b15f8ae8567088a.tar.bz2
gentoo-2-f99b135f8ce653bb458d948e4b15f8ae8567088a.zip
fix bug #15622 properly, sed mistake before
Diffstat (limited to 'eclass')
-rw-r--r--eclass/php-2.eclass8
-rw-r--r--eclass/php.eclass9
2 files changed, 6 insertions, 11 deletions
diff --git a/eclass/php-2.eclass b/eclass/php-2.eclass
index e2e04352cc28..b82bd1302825 100644
--- a/eclass/php-2.eclass
+++ b/eclass/php-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/php-2.eclass,v 1.2 2003/11/23 01:41:27 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/php-2.eclass,v 1.3 2003/12/09 05:02:59 robbat2 Exp $
# Author: Robin H. Johnson <robbat2@gentoo.org>
# This EBUILD is totally masked presently. Use it at your own risk. I know it
@@ -203,7 +203,7 @@ php_src_unpack() {
# fix PEAR installer for our packaging
# we keep a backup of it as we need it at the end of the install
cp pear/PEAR/Registry.php pear/PEAR/Registry.old
- sed -e "s:\$pear_install_dir\.:\'${D}/usr/lib/php/\' . :g" -i pear/PEAR/Registry.old
+ sed -e "s:\$pear_install_dir\.:\'${D}/usr/lib/php/\' . :g" -i pear/PEAR/Registry.php
}
@@ -442,9 +442,7 @@ php_src_install() {
# only php-core has the PEAR stuff
if [ "${PN}" = "php-core" ]; then
#revert Pear patch
- rm ${D}/usr/lib/php/PEAR/Registry.php
- #should this possibly result to the SAME original value it was ? (\$pear_install_dir)
- cat ${S}/pear/PEAR/Registry.old | sed -e 's:${PORTAGE_TMPDIR}/${PF}::' > ${D}/usr/lib/php/PEAR/Registry.php
+ cp ${S}/pear/PEAR/Registry.old ${D}/usr/lib/php/PEAR/Registry.php
fi
# Support for Java extension
diff --git a/eclass/php.eclass b/eclass/php.eclass
index 8404d50c03c9..59c7380b53a9 100644
--- a/eclass/php.eclass
+++ b/eclass/php.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/php.eclass,v 1.92 2003/11/24 06:19:09 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/php.eclass,v 1.93 2003/12/09 05:02:59 robbat2 Exp $
# Author: Robin H. Johnson <robbat2@gentoo.org>
# This EBUILD is totally masked presently. Use it at your own risk. I know it
@@ -204,7 +204,7 @@ php_src_unpack() {
# fix PEAR installer for our packaging
# we keep a backup of it as we need it at the end of the install
cp pear/PEAR/Registry.php pear/PEAR/Registry.old
- sed -e "s:\$pear_install_dir\.:\'${D}/usr/lib/php/\' . :g" -i pear/PEAR/Registry.old
+ sed -e "s:\$pear_install_dir\.:\'${D}/usr/lib/php/\' . :g" -i pear/PEAR/Registry.php
[ "${MY_PV}" = "4.3.4" ] && \
epatch ${DISTDIR}/php-4.3.4-phpizeexecfix.patch
@@ -438,11 +438,8 @@ php_src_install() {
doins build/* acinclude.m4 configure.in Makefile.global scan_makefile_in.awk
# Deprecated : pear/pear.m4
- #revert Pear patch
- rm ${D}/usr/lib/php/PEAR/Registry.php
#should this possibly result to the SAME original value it was ? (\$pear_install_dir)
- cat ${S}/pear/PEAR/Registry.old | sed -e 's:${PORTAGE_TMPDIR}/${PF}::' > ${D}/usr/lib/php/PEAR/Registry.php
-
+ cp ${S}/pear/PEAR/Registry.old ${D}/usr/lib/php/PEAR/Registry.php
# Support for Java extension
# 1. install php_java.jar file into ${EXT_DIR}