summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-09 01:57:07 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-09 01:57:07 +0000
commitf7e737716ec1f2ee7643c79e9a5e4e04e65b4d3a (patch)
treed55039698a2bd2f40e711918d09c745d4b7577c6 /eclass
parentBump. (diff)
downloadgentoo-2-f7e737716ec1f2ee7643c79e9a5e4e04e65b4d3a.tar.gz
gentoo-2-f7e737716ec1f2ee7643c79e9a5e4e04e65b4d3a.tar.bz2
gentoo-2-f7e737716ec1f2ee7643c79e9a5e4e04e65b4d3a.zip
Stub-out ez_setup.py and distribute_setup.py to prevent packages from downloading their own copy of setuptools.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/distutils-r1.eclass11
2 files changed, 15 insertions, 2 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index f09fb79a47d3..537277f976a7 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.872 2013/07/06 07:57:14 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.873 2013/07/09 01:57:07 floppym Exp $
+
+ 09 Jul 2013; Mike Gilbert <floppym@gentoo.org> distutils-r1.eclass:
+ Stub-out ez_setup.py and distribute_setup.py to prevent packages from
+ downloading their own copy of setuptools.
06 Jul 2013; Davide Pesavento <pesa@gentoo.org> qt4-build.eclass:
Update SRC_URI. Drop support for EAPI 3.
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 34637665bacd..c35022cce158 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.71 2013/05/21 01:31:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.72 2013/07/09 01:57:07 floppym Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -308,6 +308,12 @@ distutils_install_for_testing() {
esetup.py "${add_args[@]}"
}
+_disable_ez_setup() {
+ local stub="def use_setuptools(*args, **kwargs): pass"
+ [[ -f ez_setup.py ]] && echo "${stub}" > ez_setup.py
+ [[ -f distribute_setup.py ]] && echo "${stub}" > distribute_setup.py
+}
+
# @FUNCTION: distutils-r1_python_prepare_all
# @DESCRIPTION:
# The default python_prepare_all(). It applies the patches from PATCHES
@@ -330,6 +336,9 @@ distutils-r1_python_prepare_all() {
fi
fi
+ # Prevent packages from downloading their own copy of setuptools
+ _disable_ez_setup
+
if [[ ${DISTUTILS_IN_SOURCE_BUILD} && ! ${DISTUTILS_SINGLE_IMPL} ]]
then
# create source copies for each implementation