summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-01 12:18:31 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-01 12:18:31 +0000
commit972d9d51721bc7f90b8783d2b8b6946bad0844c9 (patch)
tree5978fda1efb0a6cd15d865f64b0ee911135448eb /eclass
parentstable ppc, bug #440368 (diff)
downloadgentoo-2-972d9d51721bc7f90b8783d2b8b6946bad0844c9.tar.gz
gentoo-2-972d9d51721bc7f90b8783d2b8b6946bad0844c9.tar.bz2
gentoo-2-972d9d51721bc7f90b8783d2b8b6946bad0844c9.zip
Explicitly set library build dir in out-of-source builds.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/distutils-r1.eclass9
2 files changed, 11 insertions, 3 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 30e96d8e04c8..e882d9f78156 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.492 2012/11/01 08:35:43 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.493 2012/11/01 12:18:31 mgorny Exp $
+
+ 01 Nov 2012; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Explicitly set library build dir in out-of-source builds.
01 Nov 2012; Davide Pesavento <pesa@gentoo.org> qt4-build.eclass:
Update homepage.
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 2944e7649aee..00f3d465c669 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.15 2012/10/31 14:28:02 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.16 2012/11/01 12:18:31 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -151,7 +151,12 @@ esetup.py() {
die 'Out-of-source build requested, yet BUILD_DIR unset.'
fi
- args+=( build --build-base "${BUILD_DIR}" )
+ args+=(
+ build
+ --build-base "${BUILD_DIR}"
+ # using a single directory for them helps us export ${PYTHONPATH}
+ --build-lib "${BUILD_DIR}/lib"
+ )
fi
set -- "${PYTHON:-python}" setup.py \