summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-18 04:59:30 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-18 04:59:30 +0000
commit958b3ca5b6a07f1443c196139a13f0731248ca3c (patch)
treeb9b3740fc8290ba2d5b0b8dffcbf5d7217dff955 /eclass
parentManifest fix - windowmaker-0.80.2-r4.ebuild size mismatch, ChangeLog size mis... (diff)
downloadgentoo-2-958b3ca5b6a07f1443c196139a13f0731248ca3c.tar.gz
gentoo-2-958b3ca5b6a07f1443c196139a13f0731248ca3c.tar.bz2
gentoo-2-958b3ca5b6a07f1443c196139a13f0731248ca3c.zip
dont strip out -fno- and -mno- related flags
Diffstat (limited to 'eclass')
-rw-r--r--eclass/flag-o-matic.eclass9
1 files changed, 5 insertions, 4 deletions
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 7ea326f62ce8..547e31c6df8c 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/flag-o-matic.eclass,v 1.62 2004/07/15 04:59:44 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/flag-o-matic.eclass,v 1.63 2004/07/18 04:59:30 vapier Exp $
#
# Author Bart Verwilst <verwilst@gentoo.org>
ECLASS=flag-o-matic
INHERITED="$INHERITED $ECLASS"
-IUSE="$IUSE debug"
+
+IUSE="debug"
#
#### filter-flags <flags> ####
@@ -207,7 +208,7 @@ strip-flags() {
for x in ${CFLAGS}; do
for y in ${ALLOWED_FLAGS}; do
flag=${x%%=*}
- if [ "${flag%%${y}}" = "" ]; then
+ if [ "${flag%%${y}}" = "" ] || [ "${flag:0:5}" = "-fno-" ] || [ "${flag:0:5}" = "-mno-" ] ; then
NEW_CFLAGS="${NEW_CFLAGS} ${x}"
break
fi
@@ -217,7 +218,7 @@ strip-flags() {
for x in ${CXXFLAGS}; do
for y in ${ALLOWED_FLAGS}; do
flag=${x%%=*}
- if [ "${flag%%${y}}" = "" ]; then
+ if [ "${flag%%${y}}" = "" ] || [ "${flag:0:5}" = "-fno-" ] || [ "${flag:0:5}" = "-mno-" ] ; then
NEW_CXXFLAGS="${NEW_CXXFLAGS} ${x}"
break
fi