summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-07-07 19:12:30 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-07-07 19:12:30 +0000
commit55c47ad372cb452304b91b3d01be4e29e13533eb (patch)
treee3d2ec84f009c97077b467a4f1bcb47220a695f4 /eclass
parentStable on sparc (diff)
downloadgentoo-2-55c47ad372cb452304b91b3d01be4e29e13533eb.tar.gz
gentoo-2-55c47ad372cb452304b91b3d01be4e29e13533eb.tar.bz2
gentoo-2-55c47ad372cb452304b91b3d01be4e29e13533eb.zip
making jokey happy by fixing autotools usage in php4_4-sapi.eclass and as such making =dev-lang/php-4* compile with libtool-2.2*
Diffstat (limited to 'eclass')
-rw-r--r--eclass/php4_4-sapi.eclass22
1 files changed, 7 insertions, 15 deletions
diff --git a/eclass/php4_4-sapi.eclass b/eclass/php4_4-sapi.eclass
index 68d52049e26f..14a7d61bca6d 100644
--- a/eclass/php4_4-sapi.eclass
+++ b/eclass/php4_4-sapi.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/php4_4-sapi.eclass,v 1.43 2008/05/25 09:27:48 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/php4_4-sapi.eclass,v 1.44 2008/07/07 19:12:30 hoffie Exp $
# ========================================================================
# Based on robbat2's work on the php4 sapi eclass
@@ -371,21 +371,13 @@ php4_4-sapi_src_unpack() {
fi
fi
- # Fix configure scripts to correctly support Suhosin
- einfo "Running aclocal"
- aclocal --force || die "Unable to run aclocal successfully"
- einfo "Running libtoolize"
- libtoolize --copy --force || die "Unable to run libtoolize successfully"
+ # We are heavily patching autotools base files (configure.in) because
+ # of suhosin etc., so let's regenerate the whole stuff now
- # Rebuild configure to make sure it's up to date
- einfo "Rebuilding configure script"
- autoreconf --force -W no-cross || die "Unable to regenerate configure script successfully"
-
- # Run elibtoolize
- elibtoolize
-
- # Just in case ;-)
- chmod 0755 configure || die "Failed to chmod configure to 0755"
+ # eaclocal doesn't accept --force, so we try to force re-generation
+ # this way
+ rm aclocal.m4
+ eautoreconf --force -W no-cross
}
# @FUNCTION: php4_4-sapi_src_compile