summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-03-30 04:24:15 +0000
committerOlivier Crête <tester@gentoo.org>2009-03-30 04:24:15 +0000
commit539707bf51723d3277f5a349a49a0016254c2533 (patch)
tree26bd274625f36dd08b908531a5a7e45a7eb0f4fe /eclass
parentamd64 stable, bug 264121 (diff)
downloadgentoo-2-539707bf51723d3277f5a349a49a0016254c2533.tar.gz
gentoo-2-539707bf51723d3277f5a349a49a0016254c2533.tar.bz2
gentoo-2-539707bf51723d3277f5a349a49a0016254c2533.zip
Add a few new plugins, generate all makefiles, shave wrappers need to be built
Diffstat (limited to 'eclass')
-rw-r--r--eclass/gst-plugins-bad.eclass26
-rw-r--r--eclass/gst-plugins-base.eclass20
-rw-r--r--eclass/gst-plugins-good.eclass22
-rw-r--r--eclass/gst-plugins-ugly.eclass24
4 files changed, 46 insertions, 46 deletions
diff --git a/eclass/gst-plugins-bad.eclass b/eclass/gst-plugins-bad.eclass
index e21ce81975d5..643864328356 100644
--- a/eclass/gst-plugins-bad.eclass
+++ b/eclass/gst-plugins-bad.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-bad.eclass,v 1.13 2008/12/05 22:24:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-bad.eclass,v 1.14 2009/03/30 04:24:15 tester Exp $
#
# Original Author: Saleem Abdulrasool <compnerd@gentoo.org>
@@ -20,7 +20,7 @@ my_gst_plugins_bad="opengl vcd x alsa amrwb bz2 cdaudio directfb dts divx faac
faad gsm gst_v4l2 ivorbis jack ladspa libmms mpeg2enc musepack musicbrainz
mythtv nas neon timidity wildmidi sdl sdltest sndfile soundtouch spc swfdec
theoradec x264 xvid dvb wavpack quicktime dc1394 metadata fbdev soup dirac mplex
-ofa oss4 apexsink celt dvdnav jp2k twolame"
+ofa oss4 apexsink celt dvdnav jp2k twolame mimic modplug"
#qtdemux spped tta
@@ -45,22 +45,22 @@ fi
S=${WORKDIR}/${MY_P}
gst-plugins-bad_src_unpack() {
- local makefiles
+# local makefiles
unpack ${A}
- gst-plugins10_find_plugin_dir
- cd ${S}
+# gst-plugins10_find_plugin_dir
+# cd ${S}
# Remove generation of any other Makefiles except the plugin's Makefile
- if [[ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]] ; then
- makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
- elif [[ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]] ; then
- makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
- fi
-
- sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
- -i ${S}/configure
+# if [[ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]] ; then
+# makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# elif [[ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]] ; then
+# makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# fi
+
+# sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
+# -i ${S}/configure
}
gst-plugins-bad_src_configure() {
diff --git a/eclass/gst-plugins-base.eclass b/eclass/gst-plugins-base.eclass
index db0c9aabdb02..ee2f0503ac29 100644
--- a/eclass/gst-plugins-base.eclass
+++ b/eclass/gst-plugins-base.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-base.eclass,v 1.10 2008/12/29 03:50:08 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-base.eclass,v 1.11 2009/03/30 04:24:15 tester Exp $
# Author : foser <foser@gentoo.org>
@@ -79,7 +79,7 @@ gst-plugins-base_src_configure() {
gst-plugins-base_src_unpack() {
- local makefiles
+# local makefiles
unpack ${A}
@@ -100,16 +100,16 @@ gst-plugins-base_src_unpack() {
-e "s:\$(top_builddir)/gst-libs/gst/rtp/libgstrtp:${ROOT}/usr/$(get_libdir)/libgstrtp:" \
-e "s:\${top_builddir}/gst-libs/gst/rtp/libgstrtp:${ROOT}/usr/$(get_libdir)/libgstrtp:" \
-i Makefile.in
- cd ${S}
+# cd ${S}
# Remove generation of any other Makefiles except the plugin's Makefile
- if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
- makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
- elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
- makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
- fi
- sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
- -i ${S}/configure
+# if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
+# makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
+# makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# fi
+# sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
+# -i ${S}/configure
}
diff --git a/eclass/gst-plugins-good.eclass b/eclass/gst-plugins-good.eclass
index 6914ad79a96e..a3d2391302a6 100644
--- a/eclass/gst-plugins-good.eclass
+++ b/eclass/gst-plugins-good.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-good.eclass,v 1.16 2008/12/05 20:39:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-good.eclass,v 1.17 2009/03/30 04:24:15 tester Exp $
# Author : foser <foser@gentoo.org>, zaheerm <zaheerm@gentoo.org>
@@ -77,22 +77,22 @@ gst-plugins-good_src_configure() {
gst-plugins-good_src_unpack() {
- local makefiles
+# local makefiles
unpack ${A}
# Link with the syswide installed gst-libs if needed
- gst-plugins10_find_plugin_dir
- cd ${S}
+# gst-plugins10_find_plugin_dir
+# cd ${S}
# Remove generation of any other Makefiles except the plugin's Makefile
- if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
- makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
- elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
- makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
- fi
- sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
- -i ${S}/configure
+# if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
+# makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
+# makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# fi
+# sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
+# -i ${S}/configure
}
diff --git a/eclass/gst-plugins-ugly.eclass b/eclass/gst-plugins-ugly.eclass
index bb0adb71cdd3..e9dbc3c40cfa 100644
--- a/eclass/gst-plugins-ugly.eclass
+++ b/eclass/gst-plugins-ugly.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-ugly.eclass,v 1.12 2008/12/05 21:45:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-ugly.eclass,v 1.13 2009/03/30 04:24:15 tester Exp $
# Author : foser <foser@gentoo.org>
@@ -26,7 +26,7 @@ MY_P=${MY_PN}-${PV}
# All relevant configure options for gst-plugins
# need a better way to extract these
# gst-plugins-base 0.9
-my_gst_plugins_ugly="a52dec amrnb cdio dvdread dvdnav lame id3tag mad mpeg2dec sidplay"
+my_gst_plugins_ugly="a52dec amrnb cdio dvdread dvdnav lame id3tag mad mpeg2dec sidplay twolame"
#SRC_URI="mirror://gnome/sources/gst-plugins/${PV_MAJ_MIN}/${MY_P}.tar.bz2"
SRC_URI="http://gstreamer.freedesktop.org/src/gst-plugins-ugly/${MY_P}.tar.bz2"
@@ -74,22 +74,22 @@ gst-plugins-ugly_src_configure() {
gst-plugins-ugly_src_unpack() {
- local makefiles
+# local makefiles
unpack ${A}
# Link with the syswide installed gst-libs if needed
- gst-plugins10_find_plugin_dir
- cd ${S}
+# gst-plugins10_find_plugin_dir
+# cd ${S}
# Remove generation of any other Makefiles except the plugin's Makefile
- if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
- makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
- elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
- makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
- fi
- sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
- -i ${S}/configure
+# if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
+# makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
+# makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
+# fi
+# sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
+# -i ${S}/configure
}