summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-11 20:03:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-11 20:03:51 +0000
commit3bd10ee6f3a9ffaebc64c3458d1c010409cb6b93 (patch)
tree125e1e6c016cd050b333d61fa96e10d13e5d61c4 /eclass
parentDepend on a version of gst-plugins-good/bad that has gstrtpbin (diff)
downloadgentoo-2-3bd10ee6f3a9ffaebc64c3458d1c010409cb6b93.tar.gz
gentoo-2-3bd10ee6f3a9ffaebc64c3458d1c010409cb6b93.tar.bz2
gentoo-2-3bd10ee6f3a9ffaebc64c3458d1c010409cb6b93.zip
Disallow installation into /usr/local.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index 76ed646de3c2..2f2d7d92942e 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.63 2009/09/11 12:24:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.64 2009/09/11 20:03:51 arfrever Exp $
# @ECLASS: distutils.eclass
# @MAINTAINER:
@@ -161,6 +161,10 @@ distutils_src_install() {
${python} setup.py "${DISTUTILS_GLOBAL_OPTIONS[@]}" install --root="${D}" --no-compile "$@" || die "Installation failed"
fi
+ if [[ -e "${D}usr/local" ]]; then
+ die "Illegal installation into /usr/local"
+ fi
+
local default_docs
default_docs="AUTHORS Change* CHANGELOG CONTRIBUTORS KNOWN_BUGS MAINTAINERS MANIFEST* NEWS PKG-INFO README* TODO"