summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-06-04 02:17:25 +0000
committerAron Griffis <agriffis@gentoo.org>2003-06-04 02:17:25 +0000
commit05084e0c0aa140942e4207c502b2ca574770c807 (patch)
treec59ab3cb843fb224631bc0f8eaaf16452af384e2 /eclass/vim.eclass
parentBump (diff)
downloadgentoo-2-05084e0c0aa140942e4207c502b2ca574770c807.tar.gz
gentoo-2-05084e0c0aa140942e4207c502b2ca574770c807.tar.bz2
gentoo-2-05084e0c0aa140942e4207c502b2ca574770c807.zip
fix vim.eclass to work with vim-6.2
Diffstat (limited to 'eclass/vim.eclass')
-rw-r--r--eclass/vim.eclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/eclass/vim.eclass b/eclass/vim.eclass
index 46fd9f007957..101192b7d76c 100644
--- a/eclass/vim.eclass
+++ b/eclass/vim.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.29 2003/05/25 00:38:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.30 2003/06/04 02:17:25 agriffis Exp $
# Authors:
# Ryan Phillips <rphillips@gentoo.org>
@@ -113,7 +113,7 @@ vim_src_unpack() {
}
src_compile() {
- local myconf
+ local myconf confrule
# Fix bug #18245: Prevent "make" from the following chain:
# (1) Notice configure.in is newer than auto/configure
@@ -122,7 +122,10 @@ src_compile() {
# (4) Run ./configure (with wrong args) to remake auto/config.mk
sed -i 's/ auto.config.mk:/:/' src/Makefile || die "Makefile sed failed"
rm -f src/auto/configure
- make -C src auto/configure || die "make auto/configure failed"
+ # vim-6.2 changed the name of this rule from auto/configure to autoconf
+ confrule=auto/configure
+ grep -q ^autoconf: src/Makefile && confrule=autoconf
+ make -C src $confrule || die "make $confrule failed"
# This should fix a sandbox violation.
for file in /dev/pty/s*; do