summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-09-17 19:32:49 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-09-17 19:32:49 +0000
commit560bbf63f470c1f5e60daf98b2f15ec2ce351406 (patch)
treeba2c379bbb6eddcf1f6be661048205c00169099d /eclass/vdr-plugin-2.eclass
parentMarked ~x86-solaris (diff)
downloadgentoo-2-560bbf63f470c1f5e60daf98b2f15ec2ce351406.tar.gz
gentoo-2-560bbf63f470c1f5e60daf98b2f15ec2ce351406.tar.bz2
gentoo-2-560bbf63f470c1f5e60daf98b2f15ec2ce351406.zip
better LINGUAS detection, vdr-plugin-2.eclass
Diffstat (limited to 'eclass/vdr-plugin-2.eclass')
-rw-r--r--eclass/vdr-plugin-2.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/vdr-plugin-2.eclass b/eclass/vdr-plugin-2.eclass
index ea65ea4e6e4c..5fc5cddbd960 100644
--- a/eclass/vdr-plugin-2.eclass
+++ b/eclass/vdr-plugin-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vdr-plugin-2.eclass,v 1.9 2012/08/05 19:26:36 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vdr-plugin-2.eclass,v 1.10 2012/09/17 19:32:49 hd_brummy Exp $
# @ECLASS: vdr-plugin-2.eclass
# @MAINTAINER:
@@ -262,7 +262,7 @@ linguas_support() {
for f in ${makefile_dir[*]}; do
- PLUGIN_LINGUAS=$( ls ${f}/po --ignore="*.pot" | tr \\\012 ' ' | tr -d [:upper:] | tr -d [:punct:] |sed -e "s:po::g" )
+ PLUGIN_LINGUAS=$( ls ${f}/po --ignore="*.pot" | sed -e "s:.po::g" | cut -d_ -f1 | tr \\\012 ' ' )
einfo "LINGUAS=\"${PLUGIN_LINGUAS}\""
sed -i ${f}/Makefile \