summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-16 14:30:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-16 14:30:12 +0000
commit7fb504eb13066f5fc3d7f6892b7558bbd63ac0df (patch)
treef011f50ab3e58fa4ff8b2fefcd60e396d73c827f /eclass/kde-meta.eclass
parentRemoving from the tree as it is no longer required for any architecture and i... (diff)
downloadgentoo-2-7fb504eb13066f5fc3d7f6892b7558bbd63ac0df.tar.gz
gentoo-2-7fb504eb13066f5fc3d7f6892b7558bbd63ac0df.tar.bz2
gentoo-2-7fb504eb13066f5fc3d7f6892b7558bbd63ac0df.zip
Commit the right version of it, after making sure I don't have two vim sessions running over nfs.
Diffstat (limited to 'eclass/kde-meta.eclass')
-rw-r--r--eclass/kde-meta.eclass22
1 files changed, 2 insertions, 20 deletions
diff --git a/eclass/kde-meta.eclass b/eclass/kde-meta.eclass
index c11b3531c2da..6a8aa129add4 100644
--- a/eclass/kde-meta.eclass
+++ b/eclass/kde-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.58 2005/11/16 14:13:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.59 2005/11/16 14:30:12 flameeyes Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
# Simone Gotti <motaboy@gentoo.org>
@@ -393,25 +393,7 @@ function kde-meta_src_compile() {
myconf="$myconf --disable-setgid"
fi
- # confcache support. valid only for my (danarmak's) port of stuart's confcache to portage .51,
- # not for stuart's orig version or ferringb's ebuild-daemon version.
- # this could be replaced by just using econf, but i don't want to make that change in kde.eclass
- # just yet. This way is more modular.
- callsections="$*"
- [ -z "$callsections" -o "$callsections" == "all" ] && callsections="myconf configure make"
- for section in $callsections; do
- debug-print "$FUNCNAME: now in section $section"
- if [ "$section" == "configure" ]; then
- # don't log makefile.common stuff in confcache
- [ ! -f "Makefile.in" ] && make -f admin/Makefile.common
- [ "`type -t confcache_start`" == "function" ] && confcache_start
- myconf="$EXTRA_ECONF $myconf"
- fi
- kde_src_compile $section
- if [ "$section" == "configure" ]; then
- [ "`type -t confcache_stop`" == "function" ] && confcache_stop
- fi
- done
+ kde_src_compile $*
}
function kde-meta_src_install() {