summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2007-01-18 08:22:41 +0000
committerPeter Johanson <latexer@gentoo.org>2007-01-18 08:22:41 +0000
commitc42df424ea868cf4a35df0194db867c3eff0107a (patch)
treeb599f127b5a9099342631750a09c8da3ee5a3a82 /eclass/gtk-sharp-component.eclass
parentstable x86, bug #147795 (diff)
downloadgentoo-2-c42df424ea868cf4a35df0194db867c3eff0107a.tar.gz
gentoo-2-c42df424ea868cf4a35df0194db867c3eff0107a.tar.bz2
gentoo-2-c42df424ea868cf4a35df0194db867c3eff0107a.zip
Fix compilation issue when automake-1.10 is around. Fixes bug #161093.
Diffstat (limited to 'eclass/gtk-sharp-component.eclass')
-rw-r--r--eclass/gtk-sharp-component.eclass9
1 files changed, 8 insertions, 1 deletions
diff --git a/eclass/gtk-sharp-component.eclass b/eclass/gtk-sharp-component.eclass
index 42416015c993..901ce3999794 100644
--- a/eclass/gtk-sharp-component.eclass
+++ b/eclass/gtk-sharp-component.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-component.eclass,v 1.27 2006/09/07 06:46:57 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-component.eclass,v 1.28 2007/01/18 08:22:41 latexer Exp $
# Author : Peter Johanson <latexer@gentoo.org>
# Based off of original work in gst-plugins.eclass by <foser@gentoo.org>
@@ -138,6 +138,13 @@ gtk-sharp-component_src_unpack() {
${S}/gconf/GConf/*.pc.in || die
fi
+ if [ -f "${S}/sample/gconf/Makefile.am" ]
+ then
+ # Fix install data hook (bug #161093)
+ sed -i -e 's/^install-hook/install-data-hook/' \
+ ${S}/sample/gconf/Makefile.am || die "sed failed"
+ fi
+
# disable building of samples (#16015)
sed -i -e "s:sample::" ${S}/Makefile.am || die