summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-10-31 22:14:44 +0000
committerMatti Bickel <mabi@gentoo.org>2010-10-31 22:14:44 +0000
commit33557f9e22c3465cff538a0a3215870c1c647c34 (patch)
tree88bb2bc0e95eeed8c4e38ccd20d7290b16e6abfa /eclass/fox.eclass
parentUpdate Gnome 2.32 mask. (diff)
downloadgentoo-2-33557f9e22c3465cff538a0a3215870c1c647c34.tar.gz
gentoo-2-33557f9e22c3465cff538a0a3215870c1c647c34.tar.bz2
gentoo-2-33557f9e22c3465cff538a0a3215870c1c647c34.zip
update for use with fox-1.7
Diffstat (limited to 'eclass/fox.eclass')
-rw-r--r--eclass/fox.eclass12
1 files changed, 8 insertions, 4 deletions
diff --git a/eclass/fox.eclass b/eclass/fox.eclass
index 39c727ec746d..176ed6ad64e5 100644
--- a/eclass/fox.eclass
+++ b/eclass/fox.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/fox.eclass,v 1.9 2010/09/18 11:11:34 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/fox.eclass,v 1.10 2010/10/31 22:14:44 mabi Exp $
# @ECLASS: fox.eclass
# @MAINTAINER:
@@ -101,6 +101,9 @@ fox_src_prepare() {
# Respect system CXXFLAGS
sed -i -e 's:CXXFLAGS=""::' $confFile || die "sed ${confFile} error"
+ # don't strip binaries
+ sed -i -e '/LDFLAGS="-s ${LDFLAGS}"/d' $confFile || die "sed ${confFile} error"
+
# don't build apps from top-level (i.e. x11-libs/fox)
# utils == reswrap
local d
@@ -109,9 +112,10 @@ fox_src_prepare() {
done
# use the installed reswrap for everything else
- for d in ${FOX_APPS} chart tests ; do
- sed -i -e 's:$(top_builddir)/utils/reswrap:reswrap:' \
- ${d}/Makefile.am || die "sed ${d}/Makefile.am error"
+ for d in ${FOX_APPS} chart controlpanel tests ; do
+ [[ -d ${d} ]] &&
+ (sed -i -e 's:$(top_builddir)/utils/reswrap:reswrap:' \
+ ${d}/Makefile.am || die "sed ${d}/Makefile.am error")
done
# use the installed headers and library for apps