summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2011-07-17 11:23:29 +0000
committerChristian Faulhammer <fauli@gentoo.org>2011-07-17 11:23:29 +0000
commitf49dadec17089feb49fa2512748255389a7c649d (patch)
tree4eb8d3565867a97deeaf9fa42926eafaa1dc401e /dev-vcs
parentppc/ppc64 stable wrt #366539 (diff)
downloadgentoo-2-f49dadec17089feb49fa2512748255389a7c649d.tar.gz
gentoo-2-f49dadec17089feb49fa2512748255389a7c649d.tar.bz2
gentoo-2-f49dadec17089feb49fa2512748255389a7c649d.zip
version bump and clean up
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/bzr/ChangeLog8
-rw-r--r--dev-vcs/bzr/bzr-2.3.1.ebuild133
-rw-r--r--dev-vcs/bzr/bzr-2.3.4.ebuild (renamed from dev-vcs/bzr/bzr-2.3.0.ebuild)2
3 files changed, 8 insertions, 135 deletions
diff --git a/dev-vcs/bzr/ChangeLog b/dev-vcs/bzr/ChangeLog
index a3e7b4bb39e9..ce74023b9f5f 100644
--- a/dev-vcs/bzr/ChangeLog
+++ b/dev-vcs/bzr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/bzr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.27 2011/05/29 10:03:00 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.28 2011/07/17 11:23:29 fauli Exp $
+
+*bzr-2.3.4 (17 Jul 2011)
+
+ 17 Jul 2011; Christian Faulhammer <fauli@gentoo.org> -bzr-2.3.0.ebuild,
+ -bzr-2.3.1.ebuild, +bzr-2.3.4.ebuild:
+ version bump and clean up
*bzr-2.3.3 (29 May 2011)
diff --git a/dev-vcs/bzr/bzr-2.3.1.ebuild b/dev-vcs/bzr/bzr-2.3.1.ebuild
deleted file mode 100644
index c653012dfd73..000000000000
--- a/dev-vcs/bzr/bzr-2.3.1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.3.1.ebuild,v 1.1 2011/03/22 20:19:17 fauli Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils elisp-common eutils versionator
-
-MY_P=${PN}-${PV}
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Bazaar is a next generation distributed version control system."
-HOMEPAGE="http://bazaar-vcs.org/"
-#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
-SRC_URI="http://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
-IUSE="curl doc emacs +sftp test"
-
-# Disable until https://bugs.launchpad.net/bzr/+bug/656170 is fixed.
-RESTRICT="test"
-
-RDEPEND="|| ( dev-lang/python:2.7[xml] dev-lang/python:2.6[xml] dev-lang/python:2.5[xml] dev-python/celementtree )
- curl? ( dev-python/pycurl )
- sftp? ( dev-python/paramiko )"
-
-DEPEND="emacs? ( virtual/emacs )
- test? (
- ${RDEPEND}
- dev-python/medusa
- dev-python/subunit
- dev-python/testtools
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="doc/*.txt"
-PYTHON_MODNAME="bzrlib"
-SITEFILE="71bzr-gentoo.el"
-
-src_prepare() {
- distutils_src_prepare
-
- # Don't regenerate .c files from .pyx when pyrex is found.
- epatch "${FILESDIR}/${PN}-2.2.0-no-pyrex-citon.patch"
- # Don't run lock permission tests when running as root
- # Has to be backported, tests are restricted anyway
-# epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
- # Fix permission errors when run under directories with setgid set.
- epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die
- fi
-}
-
-src_test() {
- # Some tests expect the usual pyc compiling behaviour.
- python_enable_pyc
-
- # Define tests which are known to fail below.
- local skip_tests="("
- # https://bugs.launchpad.net/bzr/+bug/456471
- skip_tests+="bzrlib.tests.blackbox.test_version.*|"
- # https://bugs.launchpad.net/bzr/+bug/392127
- skip_tests+="test_http.*"
- skip_tests+=")"
- if [[ -n ${skip_tests} ]]; then
- einfo "Skipping tests known to fail: ${skip_tests}"
- fi
-
- testing() {
- LC_ALL="C" "$(PYTHON -2)" bzr --no-plugins selftest ${skip_tests:+-x} ${skip_tests}
- }
- python_execute_function testing
-
- # Just to make sure we don't hit any errors on later stages.
- python_disable_pyc
-}
-
-src_install() {
- distutils_src_install --install-data "${EPREFIX}/usr/share"
-
- if use doc; then
- docinto developers
- dodoc doc/developers/* || die
- for doc in mini-tutorial tutorials user-{guide,reference}; do
- docinto $doc
- dodoc doc/en/$doc/* || die
- done
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${ED}${SITELISP}/${PN}/.nosearch"
- fi
-
- dobashcompletion contrib/bash/bzr
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- bash-completion_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
diff --git a/dev-vcs/bzr/bzr-2.3.0.ebuild b/dev-vcs/bzr/bzr-2.3.4.ebuild
index f11f2b9bcde4..7e286f63b588 100644
--- a/dev-vcs/bzr/bzr-2.3.0.ebuild
+++ b/dev-vcs/bzr/bzr-2.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.3.0.ebuild,v 1.1 2011/02/11 23:21:41 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.3.4.ebuild,v 1.1 2011/07/17 11:23:29 fauli Exp $
EAPI="3"
PYTHON_DEPEND="2"