summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-29 09:45:59 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-29 09:45:59 +0000
commite69e0ad49fe632b011e8917d714fc4c14c19413a (patch)
tree70565ccd89b61c9061abf85fa11edd46d8c74156 /dev-vcs
parentChange version scheme (diff)
downloadgentoo-2-e69e0ad49fe632b011e8917d714fc4c14c19413a.tar.gz
gentoo-2-e69e0ad49fe632b011e8917d714fc4c14c19413a.tar.bz2
gentoo-2-e69e0ad49fe632b011e8917d714fc4c14c19413a.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tig/ChangeLog7
-rw-r--r--dev-vcs/tig/tig-0.18.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index 042a2d78dd07..2bbaf413ce29 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.8 2011/07/15 20:25:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.9 2011/08/29 09:45:59 radhermit Exp $
+
+*tig-0.18 (29 Aug 2011)
+
+ 29 Aug 2011; Tim Harder <radhermit@gentoo.org> +tig-0.18.ebuild:
+ Version bump.
15 Jul 2011; Tim Harder <radhermit@gentoo.org> -tig-0.14.1.ebuild,
-tig-0.15.ebuild, -tig-0.16.ebuild, -tig-0.16.1.ebuild, -tig-0.16.2.ebuild:
diff --git a/dev-vcs/tig/tig-0.18.ebuild b/dev-vcs/tig/tig-0.18.ebuild
new file mode 100644
index 000000000000..c8723cbd2d96
--- /dev/null
+++ b/dev-vcs/tig/tig-0.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-0.18.ebuild,v 1.1 2011/08/29 09:45:59 radhermit Exp $
+
+EAPI=4
+
+inherit bash-completion
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS TODO
+ dohtml manual.html README.html
+ dobashcompletion contrib/tig-completion.bash
+}