summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-07-31 00:47:11 +0000
committerSebastian Pipping <sping@gentoo.org>2011-07-31 00:47:11 +0000
commitc33bd83b8287638cd7bfd9c92e83ee2a3b160c54 (patch)
treea5671d93a4dd06b764f06200f20ea59d8e4b8f25 /dev-vcs
parentRemove seemingly unnecessary fonts. (diff)
downloadgentoo-2-c33bd83b8287638cd7bfd9c92e83ee2a3b160c54.tar.gz
gentoo-2-c33bd83b8287638cd7bfd9c92e83ee2a3b160c54.tar.bz2
gentoo-2-c33bd83b8287638cd7bfd9c92e83ee2a3b160c54.zip
dev-vcs/gitg: Bump to 0.2.4
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitg/ChangeLog8
-rw-r--r--dev-vcs/gitg/gitg-0.2.4.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-vcs/gitg/ChangeLog b/dev-vcs/gitg/ChangeLog
index d9eb91668e4c..caba88c39dba 100644
--- a/dev-vcs/gitg/ChangeLog
+++ b/dev-vcs/gitg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/gitg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.12 2011/07/15 13:56:36 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.13 2011/07/31 00:47:11 sping Exp $
+
+*gitg-0.2.4 (31 Jul 2011)
+
+ 31 Jul 2011; Sebastian Pipping <sping@gentoo.org> +gitg-0.2.4.ebuild:
+ Bump to 0.2.4: Downstream patching no longer needed, newer version of
+ gtksourceview required
*gitg-0.2.2 (15 Jul 2011)
diff --git a/dev-vcs/gitg/gitg-0.2.4.ebuild b/dev-vcs/gitg/gitg-0.2.4.ebuild
new file mode 100644
index 000000000000..352be3af526a
--- /dev/null
+++ b/dev-vcs/gitg/gitg-0.2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.2.4.ebuild,v 1.1 2011/07/31 00:47:11 sping Exp $
+
+EAPI="3"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="http://trac.novowork.com/gitg/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# FIXME: debug changes CFLAGS
+IUSE="debug glade"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3.0.0:3
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ >=gnome-base/gconf-2.10:2
+ >=gnome-base/gsettings-desktop-schemas-0.1.1
+ dev-vcs/git
+ glade? ( >=dev-util/glade-3.2:3.10 )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.40"
+
+pkg_setup() {
+ # Disable maintainer to get rid of -Werror (bug #363009)
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-deprecations
+ --disable-dependency-tracking
+ --disable-maintainer-mode
+ $(use_enable debug)
+ $(use_enable glade glade-catalog)"
+
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_test() {
+ emake check || die
+}