summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-07 00:45:39 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-07 00:45:39 +0000
commitaec2766feaad9178902366ed7b290ecd1e7f13ee (patch)
tree69bfbe2e5d1182c8dc14f40e18a5b18d5b472e26 /dev-vcs
parentUpdating elog message (diff)
downloadgentoo-2-aec2766feaad9178902366ed7b290ecd1e7f13ee.tar.gz
gentoo-2-aec2766feaad9178902366ed7b290ecd1e7f13ee.tar.bz2
gentoo-2-aec2766feaad9178902366ed7b290ecd1e7f13ee.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog8
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.8.ebuild78
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild4
3 files changed, 87 insertions, 3 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 3ebad5ccfcf7..1e9177772237 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.38 2013/05/03 07:46:20 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.39 2013/05/07 00:45:39 floppym Exp $
+
+*tortoisehg-2.8 (07 May 2013)
+
+ 07 May 2013; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.8.ebuild,
+ tortoisehg-9999.ebuild:
+ Version bump.
*tortoisehg-2.7.2 (03 May 2013)
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.8.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.8.ebuild
new file mode 100644
index 000000000000..4c2bce07e5ee
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.8.ebuild,v 1.1 2013/05/07 00:45:39 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-2.5 <dev-vcs/mercurial-2.7"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ KEYWORDS=""
+ SRC_URI=""
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt4[svg,${PYTHON_USEDEP}]
+ dev-python/qscintilla-python"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${LINGUAS+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ if use doc ; then
+ dohtml -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg-logo.svg thg_logo.svg
+ domenu contrib/${PN}.desktop
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt4 please rebuild"
+ elog "dev-python/qscintilla-python."
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 56e7f74a58db..4b51b48a9942 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.19 2013/03/05 03:44:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.20 2013/05/07 00:45:39 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -10,7 +10,7 @@ inherit distutils-r1 eutils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-2.4 <dev-vcs/mercurial-2.6"
+ HG_DEPEND=">=dev-vcs/mercurial-2.5 <dev-vcs/mercurial-2.7"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"