summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-12-25 15:06:26 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-12-25 15:06:26 +0000
commita7e9ba95e2f7881689835d408b436c4aa089412f (patch)
tree938f9bf96471a826e725198ffff70c1653183b83 /dev-vcs
parentFix dependencies (bug #349672). (diff)
downloadgentoo-2-a7e9ba95e2f7881689835d408b436c4aa089412f.tar.gz
gentoo-2-a7e9ba95e2f7881689835d408b436c4aa089412f.tar.bz2
gentoo-2-a7e9ba95e2f7881689835d408b436c4aa089412f.zip
Run one test at a time, running mutiple tests at once causes a lot of issues, see bug #348854.
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/ChangeLog7
-rw-r--r--dev-vcs/mercurial/mercurial-1.7.1.ebuild4
-rw-r--r--dev-vcs/mercurial/mercurial-1.7.2.ebuild4
-rw-r--r--dev-vcs/mercurial/mercurial-1.7.ebuild4
4 files changed, 12 insertions, 7 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index e76b9cadf62f..c8fca1608304 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.29 2010/12/24 02:26:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.30 2010/12/25 15:06:26 nelchael Exp $
+
+ 25 Dec 2010; Krzysztof Pawlik <nelchael@gentoo.org> mercurial-1.7.ebuild,
+ mercurial-1.7.1.ebuild, mercurial-1.7.2.ebuild:
+ Run one test at a time, running mutiple tests at once causes a lot of issues,
+ see bug #348854.
24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
mercurial-1.6.3.ebuild, mercurial-1.6.4.ebuild, mercurial-1.7.ebuild,
diff --git a/dev-vcs/mercurial/mercurial-1.7.1.ebuild b/dev-vcs/mercurial/mercurial-1.7.1.ebuild
index 6185945fe20d..8a64ed088f60 100644
--- a/dev-vcs/mercurial/mercurial-1.7.1.ebuild
+++ b/dev-vcs/mercurial/mercurial-1.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.7.1.ebuild,v 1.2 2010/12/24 02:26:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.7.1.ebuild,v 1.3 2010/12/25 15:06:26 nelchael Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -107,7 +107,7 @@ src_test() {
testing() {
local testdir="${T}/tests-${PYTHON_ABI}"
rm -rf "${testdir}"
- "$(PYTHON)" run-tests.py -j4 --tmpdir="${testdir}"
+ "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
}
python_execute_function testing
}
diff --git a/dev-vcs/mercurial/mercurial-1.7.2.ebuild b/dev-vcs/mercurial/mercurial-1.7.2.ebuild
index 517447065f1a..63ddd6504630 100644
--- a/dev-vcs/mercurial/mercurial-1.7.2.ebuild
+++ b/dev-vcs/mercurial/mercurial-1.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.7.2.ebuild,v 1.2 2010/12/24 02:26:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.7.2.ebuild,v 1.3 2010/12/25 15:06:26 nelchael Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -107,7 +107,7 @@ src_test() {
testing() {
local testdir="${T}/tests-${PYTHON_ABI}"
rm -rf "${testdir}"
- "$(PYTHON)" run-tests.py -j4 --tmpdir="${testdir}"
+ "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
}
python_execute_function testing
}
diff --git a/dev-vcs/mercurial/mercurial-1.7.ebuild b/dev-vcs/mercurial/mercurial-1.7.ebuild
index ee9a404c0ab9..78e4e9847f78 100644
--- a/dev-vcs/mercurial/mercurial-1.7.ebuild
+++ b/dev-vcs/mercurial/mercurial-1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.7.ebuild,v 1.4 2010/12/24 02:26:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.7.ebuild,v 1.5 2010/12/25 15:06:26 nelchael Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -107,7 +107,7 @@ src_test() {
testing() {
local testdir="${T}/tests-${PYTHON_ABI}"
rm -rf "${testdir}"
- "$(PYTHON)" run-tests.py -j4 --tmpdir="${testdir}"
+ "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
}
python_execute_function testing
}