summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-08-21 15:17:33 +0000
committerMike Gilbert <floppym@gentoo.org>2012-08-21 15:17:33 +0000
commit93759bd80d7469761a80791eb5149da1e6df3f8d (patch)
treeb460c0eac183e0fa229c6c51b4400650debdf925 /dev-vcs
parentMask ipmi USE flag on all arches but x86/amd64/ia64. (diff)
downloadgentoo-2-93759bd80d7469761a80791eb5149da1e6df3f8d.tar.gz
gentoo-2-93759bd80d7469761a80791eb5149da1e6df3f8d.tar.bz2
gentoo-2-93759bd80d7469761a80791eb5149da1e6df3f8d.zip
Version bump for bug 432156 by polynomial-c.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog8
-rw-r--r--dev-vcs/tortoisehg/files/tortoisehg-2.2.2-hgversion.patch19
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.4.3.ebuild81
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild9
4 files changed, 92 insertions, 25 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index cff70cb67f68..5d8228502b58 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.20 2012/07/20 16:33:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.21 2012/08/21 15:17:33 floppym Exp $
+
+*tortoisehg-2.4.3 (21 Aug 2012)
+
+ 21 Aug 2012; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.4.3.ebuild,
+ -files/tortoisehg-2.2.2-hgversion.patch, tortoisehg-9999.ebuild:
+ Version bump for bug 432156 by polynomial-c.
20 Jul 2012; Mike Gilbert <floppym@gentoo.org> metadata.xml:
Drop nautilus use flag from metadata.
diff --git a/dev-vcs/tortoisehg/files/tortoisehg-2.2.2-hgversion.patch b/dev-vcs/tortoisehg/files/tortoisehg-2.2.2-hgversion.patch
deleted file mode 100644
index f01800bf6343..000000000000
--- a/dev-vcs/tortoisehg/files/tortoisehg-2.2.2-hgversion.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-# HG changeset patch
-# User Yuya Nishihara <yuya@tcha.org>
-# Date 1327248119 -32400
-# Node ID d5dc83c7fc47f6692887f5af6bb7b1c819e7ad8e
-# Parent 54c988c2eb8442d3cb121b8ba73973bcdcbac467
-hgversion: bump required Mercurial version to 2.0
-
-diff --git a/tortoisehg/util/hgversion.py b/tortoisehg/util/hgversion.py
---- a/tortoisehg/util/hgversion.py
-+++ b/tortoisehg/util/hgversion.py
-@@ -18,7 +18,7 @@
-
- def checkhgversion(v):
- """range check the Mercurial version"""
-- reqver = ['1', '9']
-+ reqver = ['2', '0']
- v = v.split('+')[0]
- if not v or v == 'unknown' or len(v) >= 12:
- # can't make any intelligent decisions about unknown or hashes
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.4.3.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.4.3.ebuild
new file mode 100644
index 000000000000..2da30e850e19
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.4.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.4.3.ebuild,v 1.1 2012/08/21 15:17:33 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-pypy-*"
+
+inherit distutils eutils multilib
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-2.2 <dev-vcs/mercurial-2.4"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ KEYWORDS=""
+ SRC_URI=""
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+
+ if [[ ${LINGUAS+set} ]]; then
+ pushd i18n/tortoisehg > /dev/null || die
+ local x y keep
+ for x in *.po; do
+ keep=
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=1
+ break
+ fi
+ done
+ [[ ${keep} ]] || rm "${x}" || die
+ done
+ popd > /dev/null || die
+ fi
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO
+
+ if use doc ; then
+ dohtml -r doc/build/html
+ fi
+
+ newicon -s scalable icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 2238be305612..ca30b4f85b25 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.9 2012/07/20 16:31:52 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.10 2012/08/21 15:17:33 floppym Exp $
EAPI=4
@@ -13,7 +13,7 @@ inherit distutils eutils multilib
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-2.1 <dev-vcs/mercurial-2.3"
+ HG_DEPEND=">=dev-vcs/mercurial-2.2 <dev-vcs/mercurial-2.4"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
@@ -73,10 +73,9 @@ src_install() {
dodoc doc/ReadMe*.txt doc/TODO
if use doc ; then
- dohtml -r doc/build/html || die
+ dohtml -r doc/build/html
fi
- insinto /usr/share/icons/hicolor/scalable/apps
- newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ newicon -s scalable icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
domenu contrib/${PN}.desktop
}