summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-11-04 19:17:08 +0000
committerMike Gilbert <floppym@gentoo.org>2011-11-04 19:17:08 +0000
commit92e2e204a7b8cf166d3bb2b4492da5d62e66f8fc (patch)
tree6217f04783ab8e7c0da6a956bd4e1e55fca65480 /dev-vcs
parentUse license from README.txt included in fmodapi375linux.tar.gz (diff)
downloadgentoo-2-92e2e204a7b8cf166d3bb2b4492da5d62e66f8fc.tar.gz
gentoo-2-92e2e204a7b8cf166d3bb2b4492da5d62e66f8fc.tar.bz2
gentoo-2-92e2e204a7b8cf166d3bb2b4492da5d62e66f8fc.zip
Add live ebuild.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog7
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index d1fd6ec44e95..d5cd99884ced 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.3 2011/11/04 17:44:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.4 2011/11/04 19:17:08 floppym Exp $
+
+*tortoisehg-9999 (04 Nov 2011)
+
+ 04 Nov 2011; Mike Gilbert <floppym@gentoo.org> +tortoisehg-9999.ebuild:
+ Add live ebuild.
*tortoisehg-2.1.4-r1 (04 Nov 2011)
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
new file mode 100644
index 000000000000..74dc8787ed44
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.1 2011/11/04 19:17:08 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils mercurial multilib
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+SRC_URI=""
+EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-1.9
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+
+ if ! use nautilus; then
+ rm -r "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}