summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-05-05 13:34:17 +0000
committerMark Wright <gienah@gentoo.org>2012-05-05 13:34:17 +0000
commit8f7876e7856ac5baf7d4004119fa3229a8985a74 (patch)
tree968c501f958dc950c34ce2ca833bee8fec754726 /dev-vcs
parentUnmask gcc-4.6 in Prefix (diff)
downloadgentoo-2-8f7876e7856ac5baf7d4004119fa3229a8985a74.tar.gz
gentoo-2-8f7876e7856ac5baf7d4004119fa3229a8985a74.tar.bz2
gentoo-2-8f7876e7856ac5baf7d4004119fa3229a8985a74.zip
Bump darcs to 2.8.0.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/darcs/ChangeLog8
-rw-r--r--dev-vcs/darcs/darcs-2.8.0.ebuild122
-rw-r--r--dev-vcs/darcs/files/darcs-2.8.0-mtl-2.1.patch29
3 files changed, 158 insertions, 1 deletions
diff --git a/dev-vcs/darcs/ChangeLog b/dev-vcs/darcs/ChangeLog
index 68675e20b9fa..953b464f2f10 100644
--- a/dev-vcs/darcs/ChangeLog
+++ b/dev-vcs/darcs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/darcs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/ChangeLog,v 1.30 2012/05/03 02:57:16 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/ChangeLog,v 1.31 2012/05/05 13:34:17 gienah Exp $
+
+*darcs-2.8.0 (05 May 2012)
+
+ 05 May 2012; Mark Wright <gienah@gentoo.org> +darcs-2.8.0.ebuild,
+ +files/darcs-2.8.0-mtl-2.1.patch:
+ Bump darcs to 2.8.0.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> darcs-2.4.4-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-vcs/darcs/darcs-2.8.0.ebuild b/dev-vcs/darcs/darcs-2.8.0.ebuild
new file mode 100644
index 000000000000..2d5c1d8f9ace
--- /dev/null
+++ b/dev-vcs/darcs/darcs-2.8.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/darcs-2.8.0.ebuild,v 1.1 2012/05/05 13:34:17 gienah Exp $
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal bash-completion-r1
+
+DESCRIPTION="a distributed, interactive, smart revision control system"
+HOMEPAGE="http://darcs.net/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-haskell/hashed-storage-0.5.6[profile?]
+ <dev-haskell/hashed-storage-0.6[profile?]
+ >=dev-haskell/haskeline-0.6.3[profile?]
+ <dev-haskell/haskeline-0.7[profile?]
+ =dev-haskell/html-1.0*[profile?]
+ >=dev-haskell/http-4000.0.8[profile?]
+ <dev-haskell/http-4000.3[profile?]
+ =dev-haskell/mmap-0.5*[profile?]
+ >=dev-haskell/mtl-1.0[profile?]
+ <dev-haskell/mtl-2.2[profile?]
+ >=dev-haskell/network-2.2[profile?]
+ <dev-haskell/network-2.4[profile?]
+ >=dev-haskell/parsec-2.0[profile?]
+ <dev-haskell/parsec-3.2[profile?]
+ =dev-haskell/random-1.0*[profile?]
+ >=dev-haskell/regex-compat-0.95.1[profile?]
+ =dev-haskell/tar-0.3*[profile?]
+ =dev-haskell/terminfo-0.3*[profile?]
+ >=dev-haskell/text-0.11.0.6[profile?]
+ <dev-haskell/text-0.12.0.0[profile?]
+ >=dev-haskell/vector-0.7[profile?]
+ >=dev-haskell/zlib-0.5.1.0[profile?]
+ <dev-haskell/zlib-0.6.0.0[profile?]
+ >=dev-lang/ghc-6.10.1
+ net-misc/curl
+ virtual/mta"
+
+# darcs also has a library version; we thus need $DEPEND
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ doc? ( virtual/latex-base
+ || ( dev-tex/latex2html[png]
+ dev-tex/latex2html[gif]
+ )
+ )
+ test? ( >=dev-haskell/cmdlib-0.2.1[profile?]
+ <dev-haskell/cmdlib-0.4[profile?]
+ >=dev-haskell/shellish-0.1.3[profile?]
+ <dev-haskell/shellish-0.2[profile?]
+ dev-haskell/test-framework[profile?]
+ dev-haskell/test-framework-hunit[profile?]
+ dev-haskell/test-framework-quickcheck2[profile?]
+ )
+ "
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.8.0-mtl-2.1.patch"
+
+ rm "${S}/tests/add_permissions.sh" || die "Could not rm add_permissions.sh"
+ rm "${S}/tests/send-output-v1.sh" || die "Could not rm send-output-v1.sh"
+ rm "${S}/tests/send-output-v2.sh" || die "Could not rm send-output-v2.sh"
+ rm "${S}/tests/utf8.sh" || die "Could not rm utf8.sh"
+}
+
+src_configure() {
+ # checking whether ghc supports -threaded flag
+ # Beware: http://www.haskell.org/ghc/docs/latest/html/users_guide/options-phases.html#options-linker
+ # contains: 'The ability to make a foreign call that does not block all other Haskell threads.'
+ # It might have interactivity impact.
+
+ threaded_flag=""
+ if $(ghc-getghc) --info | grep "Support SMP" | grep -q "YES"; then
+ threaded_flag="--flags=threaded"
+ einfo "$P will be built with threads support"
+ else
+ threaded_flag="--flags=-threaded"
+ einfo "$P will be built without threads support"
+ fi
+
+ # Use curl for net stuff to avoid strict version dep on HTTP and network
+ cabal_src_configure \
+ --flags=curl \
+ --flags=-http \
+ --flags=color \
+ --flags=terminfo \
+ --flags=mmap \
+ $threaded_flag \
+ $(cabal_flag test)
+}
+
+src_test() {
+ # run cabal test from haskell-cabal
+ haskell-cabal_src_test || die "cabal test failed"
+}
+
+src_install() {
+ cabal_src_install
+ newbashcomp "${S}/contrib/darcs_completion" "${PN}"
+
+ # fixup perms in such an an awkward way
+ mv "${ED}/usr/share/man/man1/darcs.1" "${S}/darcs.1" || die "darcs.1 not found"
+ doman "${S}/darcs.1" || die "failed to register darcs.1 as a manpage"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+
+ ewarn "NOTE: in order for the darcs send command to work properly,"
+ ewarn "you must properly configure your mail transport agent to relay"
+ ewarn "outgoing mail. For example, if you are using ssmtp, please edit"
+ ewarn "${EPREFIX}/etc/ssmtp/ssmtp.conf with appropriate values for your site."
+}
diff --git a/dev-vcs/darcs/files/darcs-2.8.0-mtl-2.1.patch b/dev-vcs/darcs/files/darcs-2.8.0-mtl-2.1.patch
new file mode 100644
index 000000000000..ccb7971a4beb
--- /dev/null
+++ b/dev-vcs/darcs/files/darcs-2.8.0-mtl-2.1.patch
@@ -0,0 +1,29 @@
+--- darcs-2.8.0-orig/darcs.cabal 2012-04-23 01:14:14.000000000 +1000
++++ darcs-2.8.0/darcs.cabal 2012-05-05 15:27:31.999138292 +1000
+@@ -364,7 +364,7 @@
+
+ build-depends: extensible-exceptions >= 0.1 && < 0.2,
+ regex-compat >= 0.95.1,
+- mtl >= 1.0 && < 2.1,
++ mtl >= 1.0 && < 2.2,
+ parsec >= 2.0 && < 3.2,
+ html == 1.0.*,
+ filepath >= 1.1.0.0 && < 1.5.0.0,
+@@ -525,7 +525,7 @@
+
+ build-depends: extensible-exceptions >= 0.1 && < 0.2,
+ regex-compat >= 0.95.1,
+- mtl >= 1.0 && < 2.1,
++ mtl >= 1.0 && < 2.2,
+ parsec >= 2.0 && < 3.2,
+ html == 1.0.*,
+ filepath >= 1.1.0.0 && < 1.5.0.0,
+@@ -612,7 +612,7 @@
+
+ build-depends: extensible-exceptions >= 0.1 && < 0.2,
+ regex-compat >= 0.95.1,
+- mtl >= 1.0 && < 2.1,
++ mtl >= 1.0 && < 2.2,
+ parsec >= 2.0 && < 3.2,
+ html == 1.0.*,
+ filepath >= 1.1.0.0 && < 1.5.0.0,