summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-06-20 11:45:45 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-06-20 11:45:45 +0000
commit732e0eb1178c9f486ee09c21eb0425a0000c4a03 (patch)
tree094efa373a3dd26dcbeaeaada0026c4fab0261b7 /dev-vcs
parentclean up (diff)
downloadgentoo-2-732e0eb1178c9f486ee09c21eb0425a0000c4a03.tar.gz
gentoo-2-732e0eb1178c9f486ee09c21eb0425a0000c4a03.tar.bz2
gentoo-2-732e0eb1178c9f486ee09c21eb0425a0000c4a03.zip
version bump for bug 323873 by Jack Lloyd <lloyd AT randombit DOT net>
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/monotone/ChangeLog8
-rw-r--r--dev-vcs/monotone/monotone-0.48.ebuild125
2 files changed, 132 insertions, 1 deletions
diff --git a/dev-vcs/monotone/ChangeLog b/dev-vcs/monotone/ChangeLog
index 9f1bb27bb808..983a6e779940 100644
--- a/dev-vcs/monotone/ChangeLog
+++ b/dev-vcs/monotone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/monotone
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.3 2010/05/17 17:43:33 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.4 2010/06/20 11:45:45 fauli Exp $
+
+*monotone-0.48 (20 Jun 2010)
+
+ 20 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
+ +monotone-0.48.ebuild:
+ version bump for bug 323873 by Jack Lloyd <lloyd AT randombit DOT net>
*monotone-0.47 (17 May 2010)
diff --git a/dev-vcs/monotone/monotone-0.48.ebuild b/dev-vcs/monotone/monotone-0.48.ebuild
new file mode 100644
index 000000000000..4e187a5e1a1c
--- /dev/null
+++ b/dev-vcs/monotone/monotone-0.48.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/monotone-0.48.ebuild,v 1.1 2010/06/20 11:45:45 fauli Exp $
+
+EAPI=2
+inherit bash-completion elisp-common eutils toolchain-funcs
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://monotone.ca"
+SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc emacs ipv6 nls"
+
+RDEPEND="sys-libs/zlib
+ emacs? ( virtual/emacs )
+ >=dev-libs/libpcre-7.6
+ >=dev-libs/botan-1.8.0
+ >=dev-db/sqlite-3.3.8
+ >=dev-lang/lua-5.1
+ net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.33.1
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ doc? ( sys-apps/texinfo )"
+
+pkg_setup() {
+ enewgroup monotone
+ enewuser monotone -1 -1 /var/lib/monotone monotone
+}
+
+src_prepare() {
+ if [[ $(gcc-major-version) -lt "3" ||
+ ( $(gcc-major-version) -eq "3" && $(gcc-minor-version) -le 3 ) ]]; then
+ die 'requires >=gcc-3.4'
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ emake html || die
+ fi
+
+ if use emacs; then
+ cd contrib
+ elisp-compile *.el || die
+ fi
+}
+
+src_test() {
+ if [ ${UID} != 0 ]; then
+ emake check || die "emake check failed"
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
+
+ dobashcompletion contrib/monotone.bash_completion
+
+ if use doc; then
+ dohtml -r html/*
+ dohtml -r figures
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/*.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el \
+ || die
+ fi
+
+ dodoc AUTHORS NEWS README* UPGRADE || die
+ docinto contrib
+ dodoc contrib/*
+ newconfd "${FILESDIR}"/monotone.confd monotone || die
+ newinitd "${FILESDIR}"/${PN}-0.36.initd monotone || die
+
+ insinto /etc/monotone
+ newins "${FILESDIR}"/hooks.lua hooks.lua || die
+ newins "${FILESDIR}"/read-permissions read-permissions || die
+ newins "${FILESDIR}"/write-permissions write-permissions || die
+
+ keepdir /var/lib/monotone/keys/ /var/{log,run}/monotone
+ fowners monotone:monotone /var/lib/monotone{,/keys} /var/{log,run}/monotone
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ elog
+ elog "For details and instructions to upgrade from previous versions,"
+ elog "please read /usr/share/doc/${PF}/UPGRADE.bz2"
+ elog
+ elog " 1. edit /etc/conf.d/monotone"
+ elog " 2. import the first keys to enable access with"
+ elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
+ elog " Thereafter, those with write permission can add other keys via"
+ elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
+ elog " can be used in the read-permission and write-permission files."
+ elog " 3. adjust permisions in /etc/monotone/read-permissions"
+ elog " and /etc/monotone/write-permissions"
+ elog " 4. start the daemon: /etc/init.d/monotone start"
+ elog " 5. make persistent: rc-update add monotone default"
+ elog
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}