summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-11-09 18:06:35 +0000
committerFabian Groffen <grobian@gentoo.org>2012-11-09 18:06:35 +0000
commit72b28cde78fb0b8c379f2efae8f9931775fd0d8a (patch)
tree040115ee37137d8edc9d68be188e36522b9ba373 /dev-vcs
parentInstall gtk-doc API documentation in the location where standard tools like d... (diff)
downloadgentoo-2-72b28cde78fb0b8c379f2efae8f9931775fd0d8a.tar.gz
gentoo-2-72b28cde78fb0b8c379f2efae8f9931775fd0d8a.tar.bz2
gentoo-2-72b28cde78fb0b8c379f2efae8f9931775fd0d8a.zip
Fix linking on Solaris, it needs libiconv
(Portage version: 2.2.01.21313-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog6
-rw-r--r--dev-vcs/git/git-1.8.0-r1.ebuild5
-rw-r--r--dev-vcs/git/git-9999.ebuild5
3 files changed, 13 insertions, 3 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index bcc6c8e5e3df..c38e3d3fe7ac 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.161 2012/11/02 18:40:19 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.162 2012/11/09 18:06:35 grobian Exp $
+
+ 09 Nov 2012; Fabian Groffen <grobian@gentoo.org> git-1.8.0-r1.ebuild,
+ git-9999.ebuild:
+ Fix linking on Solaris, it needs libiconv
*git-1.8.0-r1 (02 Nov 2012)
diff --git a/dev-vcs/git/git-1.8.0-r1.ebuild b/dev-vcs/git/git-1.8.0-r1.ebuild
index a6c1fba3df30..52f5d9ec32fe 100644
--- a/dev-vcs/git/git-1.8.0-r1.ebuild
+++ b/dev-vcs/git/git-1.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.0-r1.ebuild,v 1.1 2012/11/02 18:40:19 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.0-r1.ebuild,v 1.2 2012/11/09 18:06:34 grobian Exp $
EAPI=4
@@ -177,6 +177,9 @@ exportmakeopts() {
if [[ ${CHOST} == *-*-aix* ]]; then
myopts="${myopts} NO_FNMATCH_CASEFOLD=YesPlease"
fi
+ if [[ ${CHOST} == *-solaris* ]]; then
+ myopts="${myopts} NEEDS_LIBICONV=YesPlease"
+ fi
has_version '>=app-text/asciidoc-8.0' \
&& myopts="${myopts} ASCIIDOC8=YesPlease"
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index acc318137d70..d6bd8b121168 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.37 2012/08/24 03:51:48 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.38 2012/11/09 18:06:34 grobian Exp $
EAPI=4
@@ -176,6 +176,9 @@ exportmakeopts() {
if [[ ${CHOST} == *-*-aix* ]]; then
myopts="${myopts} NO_FNMATCH_CASEFOLD=YesPlease"
fi
+ if [[ ${CHOST} == *-solaris* ]]; then
+ myopts="${myopts} NEEDS_LIBICONV=YesPlease"
+ fi
has_version '>=app-text/asciidoc-8.0' \
&& myopts="${myopts} ASCIIDOC8=YesPlease"