summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-05-03 12:21:28 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-05-03 12:21:28 +0000
commit5de40ca2e7d3476c41682d7ba63efc30ef9730ec (patch)
treef5305f4e683f7dac8f0cc24fbd8bd1e87a8e8ea2 /dev-vcs
parentImport Fedora 17 security patchset for the compability SLOT. (diff)
downloadgentoo-2-5de40ca2e7d3476c41682d7ba63efc30ef9730ec.tar.gz
gentoo-2-5de40ca2e7d3476c41682d7ba63efc30ef9730ec.tar.bz2
gentoo-2-5de40ca2e7d3476c41682d7ba63efc30ef9730ec.zip
Version bump hg-git to 0.4.0.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hg-git/ChangeLog7
-rw-r--r--dev-vcs/hg-git/hg-git-0.4.0.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-vcs/hg-git/ChangeLog b/dev-vcs/hg-git/ChangeLog
index 10a927f45804..5a5c9c62dec3 100644
--- a/dev-vcs/hg-git/ChangeLog
+++ b/dev-vcs/hg-git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hg-git
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.43 2013/03/24 09:36:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.44 2013/05/03 12:21:28 djc Exp $
+
+*hg-git-0.4.0 (03 May 2013)
+
+ 03 May 2013; Dirkjan Ochtman <djc@gentoo.org> +hg-git-0.4.0.ebuild:
+ Version bump hg-git to 0.4.0.
*hg-git-0.3.4 (24 Mar 2013)
diff --git a/dev-vcs/hg-git/hg-git-0.4.0.ebuild b/dev-vcs/hg-git/hg-git-0.4.0.ebuild
new file mode 100644
index 000000000000..b3ab242ea3fe
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.4.0.ebuild,v 1.1 2013/05/03 12:21:28 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit eutils distutils
+
+DESCRIPTION="push and pull from a Git server using Mercurial"
+HOMEPAGE="http://hg-git.github.com/ http://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-vcs/mercurial-1.9
+ >=dev-python/dulwich-0.8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_MODNAME="hggit"