summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-24 17:21:54 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-24 17:21:54 +0000
commit573b67f0f9244745a871b2ce40478a09539f3e70 (patch)
tree88067868cfb139f63d23e366a306d0eeb74834e9 /dev-vcs
parentAdd patch from Debian to make apcupsd work again. This reverts the apcupsd co... (diff)
downloadgentoo-2-573b67f0f9244745a871b2ce40478a09539f3e70.tar.gz
gentoo-2-573b67f0f9244745a871b2ce40478a09539f3e70.tar.bz2
gentoo-2-573b67f0f9244745a871b2ce40478a09539f3e70.zip
dev-vcs/gitstats: Drop old; pack latest and bump to new python eclasses, #489132
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitstats/ChangeLog10
-rw-r--r--dev-vcs/gitstats/gitstats-0_pre131024.ebuild39
-rw-r--r--dev-vcs/gitstats/gitstats-100711.ebuild41
-rw-r--r--dev-vcs/gitstats/gitstats-9999.ebuild25
-rw-r--r--dev-vcs/gitstats/metadata.xml4
5 files changed, 62 insertions, 57 deletions
diff --git a/dev-vcs/gitstats/ChangeLog b/dev-vcs/gitstats/ChangeLog
index e3d87f0bd52a..586a0300bf7a 100644
--- a/dev-vcs/gitstats/ChangeLog
+++ b/dev-vcs/gitstats/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/gitstats
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/ChangeLog,v 1.3 2011/09/21 08:25:56 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/ChangeLog,v 1.4 2013/10/24 17:21:54 jlec Exp $
+
+*gitstats-0_pre131024 (24 Oct 2013)
+
+ 24 Oct 2013; Justin Lecher <jlec@gentoo.org> +gitstats-0_pre131024.ebuild,
+ gitstats-9999.ebuild, -gitstats-100711.ebuild, metadata.xml:
+ Drop old; pack latest and bump to new python eclasses, #489132
21 Sep 2011; Michał Górny <mgorny@gentoo.org> gitstats-9999.ebuild:
Migrate to git-2.
diff --git a/dev-vcs/gitstats/gitstats-0_pre131024.ebuild b/dev-vcs/gitstats/gitstats-0_pre131024.ebuild
new file mode 100644
index 000000000000..dfcc8581a6fd
--- /dev/null
+++ b/dev-vcs/gitstats/gitstats-0_pre131024.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/gitstats-0_pre131024.ebuild,v 1.1 2013/10/24 17:21:54 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1
+
+DESCRIPTION="Statistics generator for git"
+HOMEPAGE="http://gitstats.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-visualization/gnuplot[gd]
+ dev-vcs/git"
+DEPEND=""
+
+src_prepare() {
+ sed \
+ -e "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '${EPREFIX}/usr/share/gitstats':g" \
+ -i gitstats || die "failed to fix static files path"
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr VERSION="${PV}" install
+ dodoc doc/{README,*.txt}
+ python_replicate_script "${ED}"/usr/bin/${PN}
+}
diff --git a/dev-vcs/gitstats/gitstats-100711.ebuild b/dev-vcs/gitstats/gitstats-100711.ebuild
deleted file mode 100644
index 9310a1a72ae2..000000000000
--- a/dev-vcs/gitstats/gitstats-100711.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/gitstats-100711.ebuild,v 1.2 2010/07/23 07:46:04 jlec Exp $
-
-EAPI="2"
-
-PYTHON_DEPEND="2"
-
-inherit python
-
-DESCRIPTION="Statistics generator for git"
-HOMEPAGE="http://gitstats.sourceforge.net/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- sci-visualization/gnuplot[gd]
- dev-vcs/git"
-DEPEND=""
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- sed "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '/usr/share/gitstats':g" \
- -i gitstats || die "failed to fix static files path"
-}
-
-src_compile() {
- :;
-}
-
-src_install() {
- emake PREFIX="${D}"/usr VERSION="${PV}" install || die
- dodoc doc/{README,*.txt} || die "doc install failed"
-}
diff --git a/dev-vcs/gitstats/gitstats-9999.ebuild b/dev-vcs/gitstats/gitstats-9999.ebuild
index 4fc316e94ee1..2b449d049e92 100644
--- a/dev-vcs/gitstats/gitstats-9999.ebuild
+++ b/dev-vcs/gitstats/gitstats-9999.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/gitstats-9999.ebuild,v 1.3 2011/09/21 08:25:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitstats/gitstats-9999.ebuild,v 1.4 2013/10/24 17:21:54 jlec Exp $
-EAPI="2"
+EAPI=5
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python git-2
+inherit python-r1 git-2
DESCRIPTION="Statistics generator for git"
HOMEPAGE="http://gitstats.sourceforge.net/"
SRC_URI=""
-EGIT_REPO_URI="git://repo.or.cz/${PN}.git
+EGIT_REPO_URI="
+ git://repo.or.cz/${PN}.git
http://repo.or.cz/r/${PN}.git"
LICENSE="GPL-3"
@@ -24,12 +25,9 @@ RDEPEND="
dev-vcs/git"
DEPEND=""
-pkg_setup() {
- python_set_active_version 2
-}
-
src_prepare() {
- sed "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '/usr/share/gitstats':g" \
+ sed \
+ -e "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '${EPREFIX}/usr/share/gitstats':g" \
-i gitstats || die "failed to fix static files path"
}
@@ -38,6 +36,7 @@ src_compile() {
}
src_install() {
- emake PREFIX="${D}"/usr VERSION="${PV}" install || die
- dodoc doc/{README,*.txt} || die "doc install failed"
+ emake PREFIX="${D}"/usr VERSION="${PV}" install
+ dodoc doc/{README,*.txt}
+ python_replicate_script "${ED}"/usr/bin/${PN}
}
diff --git a/dev-vcs/gitstats/metadata.xml b/dev-vcs/gitstats/metadata.xml
index c1e2e62cd910..4a00a64b40ae 100644
--- a/dev-vcs/gitstats/metadata.xml
+++ b/dev-vcs/gitstats/metadata.xml
@@ -1,5 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer><email>jlec@gentoo.org</email></maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>