summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-27 08:42:31 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-27 08:42:31 +0000
commit52dc19f62fead57d69619b28530c08d6d4eec047 (patch)
tree5702a752a204000eba35040a440f005f5982c9a4 /dev-vcs
parentstable on x86 wrt #474420 (diff)
downloadgentoo-2-52dc19f62fead57d69619b28530c08d6d4eec047.tar.gz
gentoo-2-52dc19f62fead57d69619b28530c08d6d4eec047.tar.bz2
gentoo-2-52dc19f62fead57d69619b28530c08d6d4eec047.zip
Replace override of src_compile() with python_configure_all() that is a simpler solution to the pre-compile operation.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/bzr/ChangeLog6
-rw-r--r--dev-vcs/bzr/bzr-2.5.1-r1.ebuild9
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-vcs/bzr/ChangeLog b/dev-vcs/bzr/ChangeLog
index 9ebc1a6a1de3..6d6a9d1ab296 100644
--- a/dev-vcs/bzr/ChangeLog
+++ b/dev-vcs/bzr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/bzr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.69 2013/05/07 17:55:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.70 2013/10/27 08:42:31 mgorny Exp $
+
+ 27 Oct 2013; Michał Górny <mgorny@gentoo.org> bzr-2.5.1-r1.ebuild:
+ Replace override of src_compile() with python_configure_all() that is a
+ simpler solution to the pre-compile operation.
*bzr-2.5.1-r1 (07 May 2013)
diff --git a/dev-vcs/bzr/bzr-2.5.1-r1.ebuild b/dev-vcs/bzr/bzr-2.5.1-r1.ebuild
index 2c8b29685d33..2a1b55824680 100644
--- a/dev-vcs/bzr/bzr-2.5.1-r1.ebuild
+++ b/dev-vcs/bzr/bzr-2.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.5.1-r1.ebuild,v 1.1 2013/05/07 17:55:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.5.1-r1.ebuild,v 1.2 2013/10/27 08:42:31 mgorny Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -38,12 +38,9 @@ PATCHES=(
"${FILESDIR}/${P}-sphinx-test-failures.patch"
)
-src_compile() {
+python_configure_all() {
# Generate the locales first to avoid a race condition.
- python_export_best
- "${PYTHON}" setup.py build_mo || die
-
- distutils-r1_src_compile
+ esetup.py build_mo
}
python_compile() {