summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-12-28 22:32:24 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-12-28 22:32:24 +0000
commit525027c7cbf25ae7d427a6f35ab0a323223d8717 (patch)
tree8dd417c3a99233342c5e703803434d5623a44305 /dev-vcs
parentRemove broken OS X fix, thanks Laurent Bachelier (bug 451416) (diff)
downloadgentoo-2-525027c7cbf25ae7d427a6f35ab0a323223d8717.tar.gz
gentoo-2-525027c7cbf25ae7d427a6f35ab0a323223d8717.tar.bz2
gentoo-2-525027c7cbf25ae7d427a6f35ab0a323223d8717.zip
Initial version. Another speedy tool to fast-export CVS repos from ',v' files.
(Portage version: 2.2.7_p53/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs-fast-export/ChangeLog9
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.0.ebuild40
-rw-r--r--dev-vcs/cvs-fast-export/metadata.xml12
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/ChangeLog b/dev-vcs/cvs-fast-export/ChangeLog
new file mode 100644
index 000000000000..b904ab8837a1
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-vcs/cvs-fast-export
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs-fast-export/ChangeLog,v 1.1 2013/12/28 22:32:24 slyfox Exp $
+
+*cvs-fast-export-1.0 (28 Dec 2013)
+
+ 28 Dec 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +cvs-fast-export-1.0.ebuild, +metadata.xml:
+ Initial version. Another speedy tool to fast-export CVS repos from ',v' files.
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.0.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.0.ebuild
new file mode 100644
index 000000000000..49b8f8f270e9
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs-fast-export/cvs-fast-export-1.0.ebuild,v 1.1 2013/12/28 22:32:24 slyfox Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship them in tarball
+
+src_prepare() {
+ tc-export CC
+ export prefix=/usr
+
+ # respect CC, CFLAGS and LDFLAGS. don't install cvssync
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -e 's/$(INSTALL).*cvssync/#&/g' \
+ -i Makefile || die
+}
+
+src_install() {
+ default
+ dodoc README
+}
diff --git a/dev-vcs/cvs-fast-export/metadata.xml b/dev-vcs/cvs-fast-export/metadata.xml
new file mode 100644
index 000000000000..d22bbde28e2d
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ </maintainer>
+ <herd>cvs-utils</herd>
+ <upstream>
+ <remote-id type="freecode">cvs-fast-export</remote-id>
+ </upstream>
+</pkgmetadata>