summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-10-14 10:37:58 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-10-14 10:37:58 +0000
commit50b8887e12a8b058e84e9612a7a42a5c5406cc09 (patch)
tree73f3415c034bcaa23c5ed38f7153c36d26ce2fdf /dev-vcs
parentVersion bump, drop old, finally fix bug 429716 (diff)
downloadgentoo-2-50b8887e12a8b058e84e9612a7a42a5c5406cc09.tar.gz
gentoo-2-50b8887e12a8b058e84e9612a7a42a5c5406cc09.tar.bz2
gentoo-2-50b8887e12a8b058e84e9612a7a42a5c5406cc09.zip
Version bump.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs2svn/ChangeLog8
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.4.0.ebuild64
2 files changed, 70 insertions, 2 deletions
diff --git a/dev-vcs/cvs2svn/ChangeLog b/dev-vcs/cvs2svn/ChangeLog
index aab83dd9e20b..1345717f0346 100644
--- a/dev-vcs/cvs2svn/ChangeLog
+++ b/dev-vcs/cvs2svn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/cvs2svn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/ChangeLog,v 1.5 2012/03/05 20:33:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/ChangeLog,v 1.6 2012/10/14 10:37:58 robbat2 Exp $
+
+*cvs2svn-2.4.0 (14 Oct 2012)
+
+ 14 Oct 2012; Robin H. Johnson <robbat2@gentoo.org> +cvs2svn-2.4.0.ebuild:
+ Version bump.
05 Mar 2012; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Remove betelgeuse
@@ -145,4 +150,3 @@
New ebuild for cvs2svn. I'm not sure when this was separated from
subversion proper, but it isn't present in 1.0.9 which is stable on
all arches.
-
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.4.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.4.0.ebuild
new file mode 100644
index 000000000000..bd775bfbc557
--- /dev/null
+++ b/dev-vcs/cvs2svn/cvs2svn-2.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.4.0.ebuild,v 1.1 2012/10/14 10:37:58 robbat2 Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH_OR="berkdb gdbm"
+PYTHON_USE_WITH_OPT="test"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+FILEVER="49237"
+
+DESCRIPTION="Convert a CVS repository to a Subversion repository"
+HOMEPAGE="http://cvs2svn.tigris.org/"
+SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bazaar git test"
+
+DEPEND=">=dev-vcs/subversion-1.0.9"
+RDEPEND="${DEPEND}
+ bazaar? ( >=dev-vcs/bzr-1.13 )
+ git? ( >=dev-vcs/git-1.5.4.4 )
+ dev-vcs/rcs"
+
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() {
+ distutils_src_compile
+ emake man
+}
+
+src_install() {
+ distutils_src_install
+ insinto "/usr/share/${PN}"
+ doins -r contrib cvs2{svn,git,bzr}-example.options
+ doman *.1
+}
+
+src_test() {
+ # Need this because subversion is localized, but the tests aren't
+ export LC_ALL=C
+
+ testing() {
+ "$(PYTHON)" -W ignore run-tests.py
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog "Additional scripts and examples have been installed to:"
+ elog " /usr/share/${PN}/"
+}