summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-10-11 18:27:08 +0000
committerSebastian Pipping <sping@gentoo.org>2010-10-11 18:27:08 +0000
commit5032c3aee7293498c5ead22b0281e97ffba97c32 (patch)
treee5ab1715f6a94a4f3dde35a2b61b24d525c68471 /dev-vcs
parentUse unpack if our EAPI allows to unpack .xz files (diff)
downloadgentoo-2-5032c3aee7293498c5ead22b0281e97ffba97c32.tar.gz
gentoo-2-5032c3aee7293498c5ead22b0281e97ffba97c32.tar.bz2
gentoo-2-5032c3aee7293498c5ead22b0281e97ffba97c32.zip
dev-vcs/svn2git: Bump to 0_pre20101008
(Portage version: 2.2_rc92_p2/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/svn2git/ChangeLog8
-rw-r--r--dev-vcs/svn2git/svn2git-0_pre20101008.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-vcs/svn2git/ChangeLog b/dev-vcs/svn2git/ChangeLog
index 8dd9a71cf97a..225aba1a7c2b 100644
--- a/dev-vcs/svn2git/ChangeLog
+++ b/dev-vcs/svn2git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/svn2git
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.6 2010/06/22 18:51:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.7 2010/10/11 18:27:08 sping Exp $
+
+*svn2git-0_pre20101008 (11 Oct 2010)
+
+ 11 Oct 2010; Sebastian Pipping <sping@gentoo.org>
+ +svn2git-0_pre20101008.ebuild:
+ Bump to 0_pre20101008
22 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
svn2git-0_pre20100303.ebuild, svn2git-0_pre20100324.ebuild,
diff --git a/dev-vcs/svn2git/svn2git-0_pre20101008.ebuild b/dev-vcs/svn2git/svn2git-0_pre20101008.ebuild
new file mode 100644
index 000000000000..03c069fd90ae
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-0_pre20101008.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-0_pre20101008.ebuild,v 1.1 2010/10/11 18:27:08 sping Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+DESCRIPTION="Importer for one time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.hartwork.org/public/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ x11-libs/qt-core"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ sed -i 's|^\(APR_INCLUDE = /usr/include/apr-1\)\.0|\1|' "${S}"/src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}