summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2012-12-02 18:25:43 +0000
committerSebastian Pipping <sping@gentoo.org>2012-12-02 18:25:43 +0000
commit429b6dbeb9dd46e63ebe54ac7793273d30618abb (patch)
treebda4568bda7bb7db4fa42b25397774efb3fa154a /dev-vcs
parentAdd src_prepare due to eclass changes. (diff)
downloadgentoo-2-429b6dbeb9dd46e63ebe54ac7793273d30618abb.tar.gz
gentoo-2-429b6dbeb9dd46e63ebe54ac7793273d30618abb.tar.bz2
gentoo-2-429b6dbeb9dd46e63ebe54ac7793273d30618abb.zip
dev-vcs/svn2git: 1.0.6
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/svn2git/ChangeLog8
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.6-version.patch14
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.6.ebuild47
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-vcs/svn2git/ChangeLog b/dev-vcs/svn2git/ChangeLog
index 39bda7468c79..5e8fcdf71681 100644
--- a/dev-vcs/svn2git/ChangeLog
+++ b/dev-vcs/svn2git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/svn2git
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.15 2012/08/03 16:58:05 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.16 2012/12/02 18:25:42 sping Exp $
+
+*svn2git-1.0.6 (02 Dec 2012)
+
+ 02 Dec 2012; Sebastian Pipping <sping@gentoo.org> +svn2git-1.0.6.ebuild,
+ +files/svn2git-1.0.6-version.patch:
+ Bump to 1.0.6
03 Aug 2012; Michael Palimaka <kensington@gentoo.org>
svn2git-0_pre20100303.ebuild, svn2git-0_pre20100324.ebuild,
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.6-version.patch b/dev-vcs/svn2git/files/svn2git-1.0.6-version.patch
new file mode 100644
index 000000000000..00d67733a4f9
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.6-version.patch
@@ -0,0 +1,14 @@
+--- src/src.pro 2011-01-11 09:27:21.530166986 +0100
++++ src/src.pro 2011-01-11 09:30:55.743128934 +0100
+@@ -7,10 +7,7 @@
+ APR_INCLUDE = /usr/include/apr-1
+ exists(local-config.pri):include(local-config.pri)
+
+-VERSION = $$system(git --no-pager show --pretty=oneline --no-notes | head -1 | cut -b-40)
+- !isEmpty(VERSION){
+- VERSION = $${VERSION}
+- }
++VERSION = "1.0.6"
+
+ VERSTR = '\\"$${VERSION}\\"' # place quotes around the version string
+ DEFINES += VER=\"$${VERSTR}\" # create a VER macro containing the version string
diff --git a/dev-vcs/svn2git/svn2git-1.0.6.ebuild b/dev-vcs/svn2git/svn2git-1.0.6.ebuild
new file mode 100644
index 000000000000..dc61bf01eae5
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.6.ebuild,v 1.1 2012/12/02 18:25:42 sping Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ x11-libs/qt-core:4"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${P}-version.patch
+ fi
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}