summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-09 05:48:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-09 05:48:59 +0000
commit3c9d9081e267266a0d79a04d65ffed556a353f43 (patch)
tree18f94a75251bf9fdd410def387b2460419fa2d66 /dev-vcs
parentSpelling. (diff)
downloadgentoo-2-3c9d9081e267266a0d79a04d65ffed556a353f43.tar.gz
gentoo-2-3c9d9081e267266a0d79a04d65ffed556a353f43.tar.bz2
gentoo-2-3c9d9081e267266a0d79a04d65ffed556a353f43.zip
Install some documentation to make this much more useful.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-annex/ChangeLog10
-rw-r--r--dev-vcs/git-annex/git-annex-3.20111203-r1.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-vcs/git-annex/ChangeLog b/dev-vcs/git-annex/ChangeLog
index 40ecebfc9077..f17c83050bb1 100644
--- a/dev-vcs/git-annex/ChangeLog
+++ b/dev-vcs/git-annex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-annex
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/ChangeLog,v 1.2 2011/12/05 19:02:11 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/ChangeLog,v 1.3 2012/02/09 05:48:59 robbat2 Exp $
+
+*git-annex-3.20111203-r1 (09 Feb 2012)
+
+ 09 Feb 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +git-annex-3.20111203-r1.ebuild:
+ Install some documentation to make this much more useful.
05 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org>
git-annex-3.20111203.ebuild:
diff --git a/dev-vcs/git-annex/git-annex-3.20111203-r1.ebuild b/dev-vcs/git-annex/git-annex-3.20111203-r1.ebuild
new file mode 100644
index 000000000000..3277d026a3a4
--- /dev/null
+++ b/dev-vcs/git-annex/git-annex-3.20111203-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/git-annex-3.20111203-r1.ebuild,v 1.1 2012/02/09 05:48:59 robbat2 Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="manage files with git, without checking their contents into git"
+HOMEPAGE="http://git-annex.branchable.com/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.7.7" # TODO: add more deps?
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ dev-haskell/dataenc
+ dev-haskell/hs3
+ dev-haskell/hslogger
+ dev-haskell/http
+ dev-haskell/json
+ dev-haskell/missingh
+ dev-haskell/monad-control
+ >=dev-haskell/mtl-2
+ dev-haskell/network
+ dev-haskell/pcre-light
+ dev-haskell/sha
+ dev-haskell/time
+ dev-haskell/utf8-string
+ >=dev-lang/ghc-6.10.1
+ dev-lang/perl
+ doc? ( www-apps/ikiwiki net-misc/rsync )"
+# dev-lang/perl is to build the manpages
+# www-apps/ikiwiki and net-misc/rsync used to build the rest of the docs
+
+src_prepare() {
+ echo 'mans: $(mans)' >>"${S}"/Makefile
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+ use doc && emake docs
+ emake mans
+}
+
+src_install() {
+ #haskell-cabal_src_install
+ emake install DESTDIR="${D}"
+ mv "${D}"/usr/share/doc/{${PN},${PF}}
+ dodoc CHANGELOG README
+}