summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-12-30 23:59:59 +0000
committerMike Auty <ikelos@gentoo.org>2010-12-30 23:59:59 +0000
commit2ffc61e0a437ccc1b6db084d4bae83e9010e1f81 (patch)
tree3bfbe86d6d7e9896f29f32bae5848c3d148f5fd3 /dev-vcs
parentaccident, revert (diff)
downloadgentoo-2-2ffc61e0a437ccc1b6db084d4bae83e9010e1f81.tar.gz
gentoo-2-2ffc61e0a437ccc1b6db084d4bae83e9010e1f81.tar.bz2
gentoo-2-2ffc61e0a437ccc1b6db084d4bae83e9010e1f81.zip
Fix a few dependency/ebuild issues as mentioned in bug 350189.
(Portage version: 2.2.0_alpha10/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitg/ChangeLog5
-rw-r--r--dev-vcs/gitg/gitg-0.0.8.ebuild13
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-vcs/gitg/ChangeLog b/dev-vcs/gitg/ChangeLog
index 3fec0e32caaa..e88f47e8aced 100644
--- a/dev-vcs/gitg/ChangeLog
+++ b/dev-vcs/gitg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/gitg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.5 2010/12/30 22:41:28 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.6 2010/12/30 23:59:59 ikelos Exp $
+
+ 30 Dec 2010; Mike Auty <ikelos@gentoo.org> gitg-0.0.8.ebuild:
+ Fix a few dependency/ebuild issues as mentioned in bug 350189.
30 Dec 2010; Mike Auty <ikelos@gentoo.org> -gitg-0.0.1.ebuild,
-gitg-0.0.2.ebuild, -gitg-0.0.3.ebuild, -gitg-0.0.4.ebuild,
diff --git a/dev-vcs/gitg/gitg-0.0.8.ebuild b/dev-vcs/gitg/gitg-0.0.8.ebuild
index 597fd1df8b5e..bbe466d312e7 100644
--- a/dev-vcs/gitg/gitg-0.0.8.ebuild
+++ b/dev-vcs/gitg/gitg-0.0.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.0.8.ebuild,v 1.1 2010/12/30 22:41:28 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.0.8.ebuild,v 1.2 2010/12/30 23:59:59 ikelos Exp $
-EAPI="2"
+EAPI="3"
inherit gnome2
@@ -21,9 +21,9 @@ RDEPEND=">=dev-libs/glib-2.26
dev-vcs/git"
DEPEND="${RDEPEND}
- sys-devel/gettext
+ >=sys-devel/gettext-0.17
>=dev-util/pkgconfig-0.15
- >=dev-util/intltool-0.35"
+ >=dev-util/intltool-0.40"
DOCS="AUTHORS ChangeLog NEWS README"
@@ -32,6 +32,11 @@ src_prepare() {
sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i "${S}/po/Makefile.in.in" || die "sed failed"
}
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "Removal of .la files failed"
+}
+
pkg_setup() {
G2CONF="${G2CONF} --disable-bundle"
}