summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2012-02-15 07:34:39 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2012-02-15 07:34:39 +0000
commit2ef1817f28eea4b3a5deff4289c8619663b64c1e (patch)
treed4e0d5d466c268435c031f87e708de836165294a /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-2ef1817f28eea4b3a5deff4289c8619663b64c1e.tar.gz
gentoo-2-2ef1817f28eea4b3a5deff4289c8619663b64c1e.tar.bz2
gentoo-2-2ef1817f28eea4b3a5deff4289c8619663b64c1e.zip
Get files from devspace (original home is inaccessible). Fix bug 379271
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fromcvs/ChangeLog12
-rw-r--r--dev-vcs/fromcvs/files/0001-Fix-379271-require-rubygems-before-other-deps.patch50
-rw-r--r--dev-vcs/fromcvs/fromcvs-0_pre20120214.ebuild50
3 files changed, 110 insertions, 2 deletions
diff --git a/dev-vcs/fromcvs/ChangeLog b/dev-vcs/fromcvs/ChangeLog
index af5f984d5c39..483edf538c72 100644
--- a/dev-vcs/fromcvs/ChangeLog
+++ b/dev-vcs/fromcvs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/fromcvs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fromcvs/ChangeLog,v 1.3 2011/06/18 10:08:55 sochotnicky Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fromcvs/ChangeLog,v 1.4 2012/02/15 07:34:38 sochotnicky Exp $
+
+*fromcvs-0_pre20120214 (14 Feb 2012)
+
+ 14 Feb 2012; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +fromcvs-0_pre20120214.ebuild,
+ +files/0001-Fix-379271-require-rubygems-before-other-deps.patch:
+ Get files from devspace (original home is inaccessible). Fix bug 379271
+ (finally)
18 Jun 2011; Stanislav Ochotnicky <sochotnicky@gentoo.org>
fromcvs-0_pre132-r1.ebuild:
diff --git a/dev-vcs/fromcvs/files/0001-Fix-379271-require-rubygems-before-other-deps.patch b/dev-vcs/fromcvs/files/0001-Fix-379271-require-rubygems-before-other-deps.patch
new file mode 100644
index 000000000000..7ae7ac67ceab
--- /dev/null
+++ b/dev-vcs/fromcvs/files/0001-Fix-379271-require-rubygems-before-other-deps.patch
@@ -0,0 +1,50 @@
+From b8b5074b0b80769d14d8f5d0839a1d63173e51ab Mon Sep 17 00:00:00 2001
+From: Stanislav Ochotnicky <sochotnicky@redhat.com>
+Date: Tue, 14 Feb 2012 23:43:43 +0100
+Subject: [PATCH] Fix #379271 - require rubygems before other deps
+
+---
+ todb.rb | 1 +
+ togit.rb | 1 +
+ tohg.rb | 1 +
+ 3 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/todb.rb b/todb.rb
+index 73f10a2..f753477 100644
+--- a/todb.rb
++++ b/todb.rb
+@@ -14,6 +14,7 @@
+ # along with fromcvs. If not, see <http://www.gnu.org/licenses/>.
+ #
+
++require 'rubygems'
+ require 'fromcvs'
+ require 'sqlite3'
+
+diff --git a/togit.rb b/togit.rb
+index d3feb24..46fa44c 100644
+--- a/togit.rb
++++ b/togit.rb
+@@ -14,6 +14,7 @@
+ # along with fromcvs. If not, see <http://www.gnu.org/licenses/>.
+ #
+
++require 'rubygems'
+ require 'fromcvs'
+
+ require 'enumerator'
+diff --git a/tohg.rb b/tohg.rb
+index 99043cb..db3337a 100644
+--- a/tohg.rb
++++ b/tohg.rb
+@@ -14,6 +14,7 @@
+ # along with fromcvs. If not, see <http://www.gnu.org/licenses/>.
+ #
+
++require 'rubygems'
+ require 'fromcvs'
+ require 'fileutils'
+
+--
+1.7.3.4
+
diff --git a/dev-vcs/fromcvs/fromcvs-0_pre20120214.ebuild b/dev-vcs/fromcvs/fromcvs-0_pre20120214.ebuild
new file mode 100644
index 000000000000..b59fa0015903
--- /dev/null
+++ b/dev-vcs/fromcvs/fromcvs-0_pre20120214.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fromcvs/fromcvs-0_pre20120214.ebuild,v 1.1 2012/02/15 07:34:39 sochotnicky Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+inherit ruby-ng
+
+MY_PV="${PV#0_pre}"
+
+DESCRIPTION="fromcvs converts cvs to git, hg or sqlite database"
+HOMEPAGE="http://gitorious.org/fromcvs"
+# downloaded from gitorious hash, no proper tarballs available
+SRC_URI="http://dev.gentoo.org/fromcvs-${MY_PV}.tar.gz"
+
+RUBY_PATCHES="0001-Fix-379271-require-rubygems-before-other-deps.patch"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+git mercurial sqlite"
+
+RUBY_S="${PN}-${PN}"
+
+RDEPEND="${RDEPEND}
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )"
+
+ruby_add_rdepend "dev-ruby/rcsparse
+ >=dev-ruby/rbtree-0.3.0-r2
+ sqlite? ( dev-ruby/sqlite3-ruby )"
+
+all_ruby_prepare() {
+ # prepare scripts that will go into bin
+ for script in togit.rb tohg.rb todb.rb;do
+ sed -i '1 i #!/usr/bin/ruby' ${script} || die
+ mv ${script} ${script%.rb} || die
+ done
+}
+
+each_ruby_install() {
+ insinto $(ruby_rbconfig_value 'sitedir')
+ doins *.rb || die "Installation of rb files failed"
+
+ use git && dobin togit
+ use mercurial && dobin tohg
+ use sqlite && dobin todb
+}