summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-04-08 18:38:49 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-04-08 18:38:49 +0000
commit1d7ab41e1408f250f1ddebdc06e8752123f49b90 (patch)
treea7d03f972e0375c0d7335bedbfee95da526362a6 /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-1d7ab41e1408f250f1ddebdc06e8752123f49b90.tar.gz
gentoo-2-1d7ab41e1408f250f1ddebdc06e8752123f49b90.tar.bz2
gentoo-2-1d7ab41e1408f250f1ddebdc06e8752123f49b90.zip
Do not install unneeded contrib files, bug #421893, and use '@' bookmark for source checkout in 9999, patch by Nikolaj Sjujskij. Bump to 2.5.4.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/ChangeLog9
-rw-r--r--dev-vcs/mercurial/mercurial-2.5.4.ebuild152
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild20
-rw-r--r--dev-vcs/mercurial/metadata.xml5
4 files changed, 177 insertions, 9 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 02d015b3fa16..2d5a055c4ea6 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.117 2013/03/09 12:55:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.118 2013/04/08 18:38:49 maksbotan Exp $
+
+*mercurial-2.5.4 (08 Apr 2013)
+
+ 08 Apr 2013; Maxim Koltsov <maksbotan@gentoo.org> +mercurial-2.5.4.ebuild,
+ mercurial-9999.ebuild, metadata.xml:
+ Do not install unneeded contrib files, bug #421893, and use '@' bookmark for
+ source checkout in 9999, patch by Nikolaj Sjujskij. Bump to 2.5.4.
09 Mar 2013; Michał Górny <mgorny@gentoo.org> mercurial-2.5.2.ebuild:
Remove the python_configure hack since bug 460016 was fixed.
diff --git a/dev-vcs/mercurial/mercurial-2.5.4.ebuild b/dev-vcs/mercurial/mercurial-2.5.4.ebuild
new file mode 100644
index 000000000000..23dca3488e96
--- /dev/null
+++ b/dev-vcs/mercurial/mercurial-2.5.4.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.5.4.ebuild,v 1.1 2013/04/08 18:38:49 maksbotan Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bugzilla emacs gpg test tk zsh-completion"
+
+RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ gpg? ( app-crypt/gnupg )
+ tk? ( dev-lang/tk )
+ zsh-completion? ( app-shells/zsh )
+ app-misc/ca-certificates"
+DEPEND="emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments[${PYTHON_USEDEP}] )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+python_prepare_all() {
+ # fix up logic that won't work in Gentoo Prefix (also won't outside in
+ # certain cases), bug #362891
+ sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ strip-flags -ftracer -ftree-vectorize
+ # Note: make it impl-conditional if py3 is supported
+ append-flags -fno-strict-aliasing
+
+ "${PYTHON}" setup.py build_mo || die
+}
+
+python_compile_all() {
+ rm -r contrib/{win32,macosx} || die
+ if use emacs; then
+ cd contrib || die
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/bash_completion ${PN}
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg
+ fi
+
+ rm -f doc/*.?.txt || die
+ dodoc CONTRIBUTORS doc/*.txt
+ cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
+
+ dobin hgeditor
+ dobin contrib/hgk
+ python_foreach_impl python_doscript contrib/hg-ssh
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
+ *.el mercurial.spec)
+ for f in ${RM_CONTRIB[@]}; do
+ rm -rf contrib/$f || die
+ done
+
+ dodoc -r contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+ doman doc/*.?
+
+ cat > "${T}/80mercurial" <<-EOF
+HG="${EPREFIX}/usr/bin/hg"
+EOF
+ doenvd "${T}/80mercurial"
+
+ insinto /etc/mercurial/hgrc.d
+ doins "${FILESDIR}/cacerts.rc"
+}
+
+src_test() {
+ cd tests || die
+ rm -rf *svn* || die # Subversion tests fail with 1.5
+ rm -f test-archive* || die # Fails due to verbose tar output changes
+ rm -f test-convert-baz* || die # GNU Arch baz
+ rm -f test-convert-cvs* || die # CVS
+ rm -f test-convert-darcs* || die # Darcs
+ rm -f test-convert-git* || die # git
+ rm -f test-convert-mtn* || die # monotone
+ rm -f test-convert-tla* || die # GNU Arch tla
+ rm -f test-doctest* || die # doctest always fails with python 2.5.x
+ rm -f test-largefiles* || die # tends to time out
+ if [[ ${EUID} -eq 0 ]]; then
+ einfo "Removing tests which require user privileges to succeed"
+ rm -f test-command-template* || die # Test is broken when run as root
+ rm -f test-convert* || die # Test is broken when run as root
+ rm -f test-lock-badness* || die # Test is broken when run as root
+ rm -f test-permissions* || die # Test is broken when run as root
+ rm -f test-pull-permission* || die # Test is broken when run as root
+ rm -f test-clone-failure* || die
+ rm -f test-journal-exists* || die
+ rm -f test-repair-strip* || die
+ fi
+
+ cd .. || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local TEST_DIR
+
+ rm -rf "${TMPDIR}"/test
+ distutils_install_for_testing
+ cd tests || die
+ "${PYTHON}" run-tests.py --verbose \
+ --tmpdir="${TMPDIR}"/test \
+ --with-hg="${TEST_DIR}"/scripts/hg \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-vcs/cvs"
+ elog " dev-vcs/darcs"
+ elog " dev-vcs/git"
+ elog " dev-vcs/monotone"
+ elog " dev-vcs/subversion"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index adde60064d2c..a114b0dff5be 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.17 2013/01/02 08:32:19 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.18 2013/04/08 18:38:49 maksbotan Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -13,6 +13,7 @@ inherit bash-completion-r1 elisp-common eutils distutils mercurial
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="http://mercurial.selenic.com/"
EHG_REPO_URI="http://selenic.com/repo/hg"
+EHG_REVISION="@"
LICENSE="GPL-2"
SLOT="0"
@@ -70,13 +71,21 @@ src_install() {
dodoc CONTRIBUTORS README doc/*.txt || die
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
dobin hgeditor || die
dobin contrib/hgk || die
dobin contrib/hg-ssh || die
- rm -f contrib/hgk contrib/hg-ssh || die
+ local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
+ *.el mercurial.spec)
+ for f in ${RM_CONTRIB[@]}; do
+ rm -rf contrib/$f || die
+ done
- rm -f contrib/bash_completion || die
cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
doman doc/*.? || die
@@ -85,11 +94,6 @@ HG="${EPREFIX}/usr/bin/hg"
EOF
doenvd "${T}/80mercurial" || die
- if use emacs; then
- elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
insinto /etc/mercurial/hgrc.d
doins "${FILESDIR}/cacerts.rc"
}
diff --git a/dev-vcs/mercurial/metadata.xml b/dev-vcs/mercurial/metadata.xml
index ee9de838f735..99bab8db6469 100644
--- a/dev-vcs/mercurial/metadata.xml
+++ b/dev-vcs/mercurial/metadata.xml
@@ -9,6 +9,11 @@
<email>polynomial-c@gentoo.org</email>
<name>Lars Wendler</name>
</maintainer>
+ <maintainer>
+ <email>sterkrig@myopera.com</email>
+ <name>Nikolaj Sjujskij</name>
+ <description>Fallback maintaner, please CC on bugs</description>
+ </maintainer>
<use>
<flag name="bugzilla">Support bugzilla integration.</flag>
<flag name="gpg">Support signing with GnuPG.</flag>