summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-12-25 18:49:32 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-12-25 18:49:32 +0000
commit0095fc8dc4bb076875d5d5ab6ed1a2047f109fc2 (patch)
tree4c47bdaf4a1deb44d24e4c7be57a4f04365b5ee7 /dev-vcs
parentadded static-libs flag (diff)
downloadgentoo-2-0095fc8dc4bb076875d5d5ab6ed1a2047f109fc2.tar.gz
gentoo-2-0095fc8dc4bb076875d5d5ab6ed1a2047f109fc2.tar.bz2
gentoo-2-0095fc8dc4bb076875d5d5ab6ed1a2047f109fc2.zip
Improve output phase of src_test block for new stables.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog6
-rw-r--r--dev-vcs/git/git-1.7.2.5.ebuild9
-rw-r--r--dev-vcs/git/git-1.7.3.4-r1.ebuild9
3 files changed, 17 insertions, 7 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 3fd9fc0696c4..2747e43d05f9 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.60 2010/12/23 22:46:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.61 2010/12/25 18:49:32 robbat2 Exp $
+
+ 25 Dec 2010; Robin H. Johnson <robbat2@gentoo.org> git-1.7.2.5.ebuild,
+ git-1.7.3.4-r1.ebuild:
+ Improve output phase of src_test block for new stables.
23 Dec 2010; Jeroen Roovers <jer@gentoo.org> git-1.7.3.4-r1.ebuild:
Stable for HPPA PPC (bug #349045).
diff --git a/dev-vcs/git/git-1.7.2.5.ebuild b/dev-vcs/git/git-1.7.2.5.ebuild
index 98fac53896cf..42f26b3bc805 100644
--- a/dev-vcs/git/git-1.7.2.5.ebuild
+++ b/dev-vcs/git/git-1.7.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2.5.ebuild,v 1.6 2010/12/23 16:06:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2.5.ebuild,v 1.7 2010/12/25 18:49:32 robbat2 Exp $
EAPI=3
@@ -441,8 +441,11 @@ src_test() {
cd "${S}"
# Now run the tests
einfo "Start test run"
- git_emake \
- test || die "tests failed"
+ git_emake test
+ rc=$?
+ # Display nice results
+ git_emake aggregate-results
+ [ $rc -eq 0 ] || die "tests failed. Please file a bug with ${S}/t/ attached."
}
showpkgdeps() {
diff --git a/dev-vcs/git/git-1.7.3.4-r1.ebuild b/dev-vcs/git/git-1.7.3.4-r1.ebuild
index 3d4f931c79e3..2f4c48584ac0 100644
--- a/dev-vcs/git/git-1.7.3.4-r1.ebuild
+++ b/dev-vcs/git/git-1.7.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.4-r1.ebuild,v 1.4 2010/12/23 22:46:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.4-r1.ebuild,v 1.5 2010/12/25 18:49:32 robbat2 Exp $
EAPI=3
@@ -437,8 +437,11 @@ src_test() {
cd "${S}"
# Now run the tests
einfo "Start test run"
- git_emake \
- test || die "tests failed"
+ git_emake test
+ rc=$?
+ # Display nice results
+ git_emake aggregate-results
+ [ $rc -eq 0 ] || die "tests failed. Please file a bug with ${S}/t/ attached."
}
showpkgdeps() {