summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-02-24 23:27:17 +0000
committerMike Gilbert <floppym@gentoo.org>2012-02-24 23:27:17 +0000
commitad0349ca801e5925759c4a55a8aa90a2a64e6962 (patch)
tree946400a7536c9ea5620e7fd35d5bb3b4c78a28bb /dev-vcs/tortoisehg
parentDepend on pango[X] (bug #405657, thanks to Piotr Szymaniak for reporting). (diff)
downloadgentoo-2-ad0349ca801e5925759c4a55a8aa90a2a64e6962.tar.gz
gentoo-2-ad0349ca801e5925759c4a55a8aa90a2a64e6962.tar.bz2
gentoo-2-ad0349ca801e5925759c4a55a8aa90a2a64e6962.zip
Version bump.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog7
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.3.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 8b7430d7be6e..e3c32f0b0eb3 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.10 2012/02/12 02:19:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.11 2012/02/24 23:27:17 floppym Exp $
+
+*tortoisehg-2.3 (24 Feb 2012)
+
+ 24 Feb 2012; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.3.ebuild:
+ Version bump.
12 Feb 2012; Mike Gilbert <floppym@gentoo.org>
-files/tortoisehg-2.1.4-mercurial-2.patch, tortoisehg-9999.ebuild:
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild
new file mode 100644
index 000000000000..d5e08287f046
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.3.ebuild,v 1.1 2012/02/24 23:27:17 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils multilib
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ KEYWORDS=""
+ SRC_URI=""
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-2.0
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+
+ if ! use nautilus; then
+ rm -r "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}