summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-09 19:16:01 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-09 19:16:01 +0000
commit2ff6c9b6e1a86599a36cf39aabe887a91c0495c8 (patch)
tree644211f216bbf616107125917ea4ddbe3bda0723 /dev-vcs/tortoisehg
parentVersion bump. (diff)
downloadgentoo-2-2ff6c9b6e1a86599a36cf39aabe887a91c0495c8.tar.gz
gentoo-2-2ff6c9b6e1a86599a36cf39aabe887a91c0495c8.tar.bz2
gentoo-2-2ff6c9b6e1a86599a36cf39aabe887a91c0495c8.zip
Convert to distutils-r1.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog5
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild46
2 files changed, 24 insertions, 27 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 850260afe88b..0666eb32f7fd 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.29 2013/01/04 08:23:56 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.30 2013/02/09 19:16:01 floppym Exp $
+
+ 09 Feb 2013; Mike Gilbert <floppym@gentoo.org> tortoisehg-9999.ebuild:
+ Convert to distutils-r1.
04 Jan 2013; Lars Wendler <polynomial-c@gentoo.org> tortoisehg-2.6.2.ebuild:
Use official upstream tarball.
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index a66ed5713814..44a573f82e8c 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,14 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.13 2012/11/24 22:37:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.14 2013/02/09 19:16:01 floppym Exp $
-EAPI=4
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2:2.5"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-pypy-*"
-
-inherit distutils eutils
+inherit distutils-r1 eutils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
@@ -17,6 +14,7 @@ if [[ ${PV} != *9999* ]]; then
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
KEYWORDS=""
SRC_URI=""
HG_DEPEND="dev-vcs/mercurial"
@@ -30,16 +28,19 @@ SLOT="0"
IUSE="doc"
RDEPEND="${HG_DEPEND}
- dev-python/iniparse
- dev-python/pygments
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt4
dev-python/qscintilla-python"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
-src_prepare() {
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
if [[ ${LINGUAS+set} ]]; then
- pushd i18n/tortoisehg > /dev/null || die
+ cd i18n/tortoisehg || die
local x y keep
for x in *.po; do
keep=false
@@ -51,28 +52,21 @@ src_prepare() {
done
${keep} || rm "${x}" || die
done
- popd > /dev/null || die
+ cd "${S}" || die
fi
-
- distutils_src_prepare
+ distutils-r1_python_prepare_all
}
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- emake -C doc html
- fi
+python_compile_all() {
+ use doc && emake -C doc html
}
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
dodoc doc/ReadMe*.txt doc/TODO
-
if use doc ; then
- dohtml -r doc/build/html
+ dohtml -r doc/build/html/
fi
-
newicon -s scalable icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
domenu contrib/${PN}.desktop
}