summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-28 03:57:04 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-28 03:57:04 +0000
commit0e22a61cc2b48222e10008ae8d0f574a043d626f (patch)
tree4e9cc30e32c191db02d076cbf2bd8a70bc8b2c98 /dev-vcs/tortoisehg
parentwand/wandtest.sh from testsuite needs USE="corefonts truetype" enabled (diff)
downloadgentoo-2-0e22a61cc2b48222e10008ae8d0f574a043d626f.tar.gz
gentoo-2-0e22a61cc2b48222e10008ae8d0f574a043d626f.tar.bz2
gentoo-2-0e22a61cc2b48222e10008ae8d0f574a043d626f.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog9
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild69
2 files changed, 76 insertions, 2 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 165c4804b351..fa4939cb6489 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tortoisehg
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.7 2011/12/10 04:42:45 floppym Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.8 2012/01/28 03:57:04 floppym Exp $
+
+*tortoisehg-2.2.2 (28 Jan 2012)
+
+ 28 Jan 2012; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.2.2.ebuild:
+ Version bump.
10 Dec 2011; Mike Gilbert <floppym@gentoo.org> tortoisehg-9999.ebuild:
Update live ebuild.
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild
new file mode 100644
index 000000000000..9bf73aa0825c
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.2.2.ebuild,v 1.1 2012/01/28 03:57:04 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils multilib
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ KEYWORDS=""
+ SRC_URI=""
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-1.9
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+
+ if ! use nautilus; then
+ rm -r "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}