summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-21 10:05:56 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-21 10:05:56 +0000
commit1cc49e762ea3b20cfbc278b4276230cc7159be42 (patch)
treee80746f0d8c21ff7bf62272c5fcb0577e0d5c5e0 /dev-vcs/tkcvs
parentRestrict media-libs/lcms depend to old version. (diff)
downloadgentoo-2-1cc49e762ea3b20cfbc278b4276230cc7159be42.tar.gz
gentoo-2-1cc49e762ea3b20cfbc278b4276230cc7159be42.tar.bz2
gentoo-2-1cc49e762ea3b20cfbc278b4276230cc7159be42.zip
Version Bump, cleaned up DESCRIPTION
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tkcvs')
-rw-r--r--dev-vcs/tkcvs/ChangeLog8
-rw-r--r--dev-vcs/tkcvs/tkcvs-8.0.4.ebuild4
-rw-r--r--dev-vcs/tkcvs/tkcvs-8.2.2.ebuild44
-rw-r--r--dev-vcs/tkcvs/tkcvs-8.2.ebuild4
4 files changed, 55 insertions, 5 deletions
diff --git a/dev-vcs/tkcvs/ChangeLog b/dev-vcs/tkcvs/ChangeLog
index 0a086439fc39..41f5343195b5 100644
--- a/dev-vcs/tkcvs/ChangeLog
+++ b/dev-vcs/tkcvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tkcvs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tkcvs/ChangeLog,v 1.1 2010/06/21 09:52:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tkcvs/ChangeLog,v 1.2 2010/06/21 10:05:56 jlec Exp $
+
+*tkcvs-8.2.2 (21 Jun 2010)
+
+ 21 Jun 2010; Justin Lecher <jlec@gentoo.org> tkcvs-8.0.4.ebuild,
+ tkcvs-8.2.ebuild, +tkcvs-8.2.2.ebuild:
+ Version Bump, cleaned up DESCRIPTION
21 Jun 2010; Justin Lecher <jlec@gentoo.org> +tkcvs-8.0.4.ebuild,
+tkcvs-8.2.ebuild, +metadata.xml:
diff --git a/dev-vcs/tkcvs/tkcvs-8.0.4.ebuild b/dev-vcs/tkcvs/tkcvs-8.0.4.ebuild
index 2c3a65df62ff..0a0e46cb4d8f 100644
--- a/dev-vcs/tkcvs/tkcvs-8.0.4.ebuild
+++ b/dev-vcs/tkcvs/tkcvs-8.0.4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tkcvs/tkcvs-8.0.4.ebuild,v 1.1 2010/06/21 09:52:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tkcvs/tkcvs-8.0.4.ebuild,v 1.2 2010/06/21 10:05:56 jlec Exp $
inherit eutils
MY_P=${PN}_${PV//./_}
-DESCRIPTION="TkCVS is a Tcl/Tk-based graphical interface to CVS."
+DESCRIPTION="Tcl/Tk-based graphical interface to CVS with Subversion support"
SRC_URI="http://www.twobarleycorns.net/${MY_P}.tar.gz"
HOMEPAGE="http://www.twobarleycorns.net/tkcvs.html"
diff --git a/dev-vcs/tkcvs/tkcvs-8.2.2.ebuild b/dev-vcs/tkcvs/tkcvs-8.2.2.ebuild
new file mode 100644
index 000000000000..fb90ca1eadb3
--- /dev/null
+++ b/dev-vcs/tkcvs/tkcvs-8.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tkcvs/tkcvs-8.2.2.ebuild,v 1.1 2010/06/21 10:05:56 jlec Exp $
+
+inherit eutils
+
+MY_P=${PN}_${PV//./_}
+DESCRIPTION="Tcl/Tk-based graphical interface to CVS with Subversion support"
+SRC_URI="http://www.twobarleycorns.net/${MY_P}.tar.gz"
+HOMEPAGE="http://www.twobarleycorns.net/tkcvs.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/tk-8.4"
+RDEPEND="${DEPEND}
+ dev-vcs/cvs
+ dev-util/subversion
+ sys-apps/diffutils
+ dev-util/tkdiff"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "/set MANDIR/s/man man1/share man man1/" \
+ -e "/set LIBDIR/s/lib/$(get_libdir)/" \
+ -i doinstall.tcl || die
+}
+
+src_install() {
+ # bug 66030
+ unset DISPLAY
+ ./doinstall.tcl -nox "${D}"/usr || die
+
+ # dev-tcktk/tkdiff
+ rm "${D}"/usr/bin/tkdiff
+
+ # Add docs...this is important
+ dodoc CHANGELOG FAQ
+}
diff --git a/dev-vcs/tkcvs/tkcvs-8.2.ebuild b/dev-vcs/tkcvs/tkcvs-8.2.ebuild
index 6b58c76f10a5..fa9006127eaf 100644
--- a/dev-vcs/tkcvs/tkcvs-8.2.ebuild
+++ b/dev-vcs/tkcvs/tkcvs-8.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tkcvs/tkcvs-8.2.ebuild,v 1.1 2010/06/21 09:52:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tkcvs/tkcvs-8.2.ebuild,v 1.2 2010/06/21 10:05:56 jlec Exp $
inherit eutils
MY_P=${PN}_${PV//./_}
-DESCRIPTION="TkCVS is a Tcl/Tk-based graphical interface to CVS."
+DESCRIPTION="Tcl/Tk-based graphical interface to CVS with Subversion support"
SRC_URI="http://www.twobarleycorns.net/${MY_P}.tar.gz"
HOMEPAGE="http://www.twobarleycorns.net/tkcvs.html"