summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-07 03:20:57 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-07 03:20:57 +0000
commit912329e2a85a86a5a43e999d4155c18a64568a82 (patch)
tree3a57b386a84931a0c76a4dfbc39731913945ff53 /dev-vcs/tig/tig-0.17.ebuild
parentInitial commit (diff)
downloadgentoo-2-912329e2a85a86a5a43e999d4155c18a64568a82.tar.gz
gentoo-2-912329e2a85a86a5a43e999d4155c18a64568a82.tar.bz2
gentoo-2-912329e2a85a86a5a43e999d4155c18a64568a82.zip
Version bump. Update to EAPI 4 and add myself as a maintainer.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tig/tig-0.17.ebuild')
-rw-r--r--dev-vcs/tig/tig-0.17.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/tig/tig-0.17.ebuild b/dev-vcs/tig/tig-0.17.ebuild
new file mode 100644
index 000000000000..4b1a721c726e
--- /dev/null
+++ b/dev-vcs/tig/tig-0.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-0.17.ebuild,v 1.1 2011/03/07 03:20:57 radhermit Exp $
+
+EAPI=4
+
+inherit bash-completion
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS TODO
+ dohtml manual.html README.html
+ dobashcompletion contrib/tig-completion.bash
+}