summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-06 20:48:09 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-06 20:48:09 +0000
commitc685462bc3467cc7a01b5a34946a26b7046b5903 (patch)
tree03c48e09a79f49c05861d7e190028ab10a6374b8 /dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild
parentBug #300352: Fix perl bindings. (diff)
downloadgentoo-2-c685462bc3467cc7a01b5a34946a26b7046b5903.tar.gz
gentoo-2-c685462bc3467cc7a01b5a34946a26b7046b5903.tar.bz2
gentoo-2-c685462bc3467cc7a01b5a34946a26b7046b5903.zip
Move package from dev-util to dev-vcs, bug 56967.
(Portage version: 2.2_rc65/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild')
-rw-r--r--dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild b/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild
new file mode 100644
index 000000000000..dd9cb3cec352
--- /dev/null
+++ b/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild,v 1.1 2010/03/06 20:48:08 ulm Exp $
+
+EAPI=2
+
+inherit distutils eutils
+
+DESCRIPTION="A subversion commit notifier written in Python"
+HOMEPAGE="http://opensource.perlig.de/svnmailer/"
+SRC_URI="http://storage.perlig.de/svnmailer/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}
+ dev-util/subversion[python]
+ virtual/mta"
+
+DOCS="CHANGES NOTICE CREDITS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-python2.5.diff
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r docs/* || die "failed to install HTML documentation"
+}