summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-04-06 17:07:14 +0000
committerSebastian Pipping <sping@gentoo.org>2011-04-06 17:07:14 +0000
commit97a375c029ff2b4a8b57063ac8cac5d52ecfca3d (patch)
tree02ee5221b994c1ae2aa16269a83fd7c8baff0469 /dev-vcs/svn2git
parentUse Python 2 (bug #361499). (diff)
downloadgentoo-2-97a375c029ff2b4a8b57063ac8cac5d52ecfca3d.tar.gz
gentoo-2-97a375c029ff2b4a8b57063ac8cac5d52ecfca3d.tar.bz2
gentoo-2-97a375c029ff2b4a8b57063ac8cac5d52ecfca3d.zip
dev-vcs/svn2git: Bump to 1.0.3
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/svn2git')
-rw-r--r--dev-vcs/svn2git/ChangeLog10
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.3-backup-refs.patch45
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.3_p1-version.patch14
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.3_p1.ebuild50
-rw-r--r--dev-vcs/svn2git/svn2git-9999.ebuild13
5 files changed, 126 insertions, 6 deletions
diff --git a/dev-vcs/svn2git/ChangeLog b/dev-vcs/svn2git/ChangeLog
index 00c843715390..deafe0e2204a 100644
--- a/dev-vcs/svn2git/ChangeLog
+++ b/dev-vcs/svn2git/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/svn2git
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.9 2011/01/11 08:43:47 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.10 2011/04/06 17:07:13 sping Exp $
+
+*svn2git-1.0.3_p1 (06 Apr 2011)
+
+ 06 Apr 2011; Sebastian Pipping <sping@gentoo.org> +svn2git-1.0.3_p1.ebuild,
+ +files/svn2git-1.0.3-backup-refs.patch,
+ +files/svn2git-1.0.3_p1-version.patch, svn2git-9999.ebuild:
+ Bump to 1.0.3 plus commit 584005f2e26149282aa12c4a0367d250caaf3918 by
+ upstream (creating backup refs for deleted branches), sync live ebuild
*svn2git-1.0.2.1 (11 Jan 2011)
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.3-backup-refs.patch b/dev-vcs/svn2git/files/svn2git-1.0.3-backup-refs.patch
new file mode 100644
index 000000000000..6241bb765331
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.3-backup-refs.patch
@@ -0,0 +1,45 @@
+From 584005f2e26149282aa12c4a0367d250caaf3918 Mon Sep 17 00:00:00 2001
+From: Jehan Bing <nahor.j@gmail.com>
+Date: Thu, 10 Mar 2011 10:54:52 -0800
+Subject: [PATCH] Create backup reference before deletion of the original branch
+
+Ensure that the backup reference is created before deleting the original
+branch. As it was, the deletion was executed earlier causing the backup
+reference to point to a non-existing branch so was not created.
+---
+ src/repository.cpp | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/src/repository.cpp b/src/repository.cpp
+index 7de840f..2c70bf3 100644
+--- a/src/repository.cpp
++++ b/src/repository.cpp
+@@ -349,11 +349,12 @@ int Repository::resetBranch(const QString &branch, int revnum, int mark, const Q
+ branchRef.prepend("refs/heads/");
+
+ Branch &br = branches[branch];
++ QByteArray backupCmd;
+ if (br.created && br.created != revnum && !br.marks.isEmpty() && br.marks.last()) {
+ QByteArray backupBranch = "refs/backups/r" + QByteArray::number(revnum) + branchRef.mid(4);
+ qWarning() << "WARN: backing up branch" << branch << "to" << backupBranch;
+
+- resetBranches.append("reset " + backupBranch + "\nfrom " + branchRef + "\n\n");
++ backupCmd = "reset " + backupBranch + "\nfrom " + branchRef + "\n\n";
+ }
+
+ br.created = revnum;
+@@ -365,9 +366,9 @@ int Repository::resetBranch(const QString &branch, int revnum, int mark, const Q
+ + " branch " + branch.toUtf8() + " = :" + QByteArray::number(mark)
+ + " # " + comment + "\n\n";
+ if(comment == "delete")
+- deletedBranches.append(cmd);
++ deletedBranches.append(backupCmd).append(cmd);
+ else
+- resetBranches.append(cmd);
++ resetBranches.append(backupCmd).append(cmd);
+
+ return EXIT_SUCCESS;
+ }
+--
+1.7.4.1
+
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.3_p1-version.patch b/dev-vcs/svn2git/files/svn2git-1.0.3_p1-version.patch
new file mode 100644
index 000000000000..78efb87c5696
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.3_p1-version.patch
@@ -0,0 +1,14 @@
+--- src/src.pro 2011-01-11 09:27:21.530166986 +0100
++++ src/src.pro 2011-01-11 09:30:55.743128934 +0100
+@@ -7,10 +7,7 @@
+ APR_INCLUDE = /usr/include/apr-1
+ exists(local-config.pri):include(local-config.pri)
+
+-VERSION = $$system(git --no-pager show --pretty=oneline --no-notes | head -1 | cut -b-40)
+- !isEmpty(VERSION){
+- VERSION = $${VERSION}
+- }
++VERSION = "1.0.3_p1"
+
+ VERSTR = '\\"$${VERSION}\\"' # place quotes around the version string
+ DEFINES += VER=\"$${VERSTR}\" # create a VER macro containing the version string
diff --git a/dev-vcs/svn2git/svn2git-1.0.3_p1.ebuild b/dev-vcs/svn2git/svn2git-1.0.3_p1.ebuild
new file mode 100644
index 000000000000..dc49c852906c
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.3_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.3_p1.ebuild,v 1.1 2011/04/06 17:07:13 sping Exp $
+
+EAPI="2"
+
+inherit versionator eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+MY_PV=$(get_version_component_range 1-3)
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${MY_PV} -> ${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ x11-libs/qt-core"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${PN}-1.0.3_p1-version.patch
+ epatch "${FILESDIR}"/${PN}-1.0.3-backup-refs.patch
+ fi
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}
diff --git a/dev-vcs/svn2git/svn2git-9999.ebuild b/dev-vcs/svn2git/svn2git-9999.ebuild
index a97dd08528f3..ee1909ba2f9c 100644
--- a/dev-vcs/svn2git/svn2git-9999.ebuild
+++ b/dev-vcs/svn2git/svn2git-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.4 2011/01/11 08:43:47 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.5 2011/04/06 17:07:13 sping Exp $
EAPI="2"
-inherit eutils qt4-r2
+inherit versionator eutils qt4-r2
[ "$PV" == "9999" ] && inherit git
-MY_PV="1.0.2-1-gebac099"
+MY_PV=$(get_version_component_range 1-3)
DESCRIPTION="Tool for one-time conversion from svn to git."
HOMEPAGE="http://gitorious.org/svn2git/svn2git"
@@ -15,7 +15,7 @@ if [ "$PV" == "9999" ]; then
EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
KEYWORDS=""
else
- SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${MY_PV} -> ${P}.tar.gz"
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${MY_PV} -> ${MY_PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -34,7 +34,10 @@ S=${WORKDIR}/${PN}-${PN}
src_prepare() {
# Note: patching order matters
epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
- [ "$PV" != "9999" ] && epatch "${FILESDIR}"/${PN}-1.0.2.1-version.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${PN}-1.0.3_p1-version.patch
+ epatch "${FILESDIR}"/${PN}-1.0.3-backup-refs.patch
+ fi
qt4-r2_src_prepare
}