summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2012-12-03 19:20:25 +0000
committerSebastian Pipping <sping@gentoo.org>2012-12-03 19:20:25 +0000
commitba49b923b7c13aa07f6744f766a9fd4cb298a35b (patch)
treeb9b91de9f78f0a8768a0788f8f0349ed470e7b99 /dev-vcs/svn2git/svn2git-1.0.8.ebuild
parentVersion bump. (diff)
downloadgentoo-2-ba49b923b7c13aa07f6744f766a9fd4cb298a35b.tar.gz
gentoo-2-ba49b923b7c13aa07f6744f766a9fd4cb298a35b.tar.bz2
gentoo-2-ba49b923b7c13aa07f6744f766a9fd4cb298a35b.zip
dev-vcs/svn2git: 1.0.8
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'dev-vcs/svn2git/svn2git-1.0.8.ebuild')
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/svn2git/svn2git-1.0.8.ebuild b/dev-vcs/svn2git/svn2git-1.0.8.ebuild
new file mode 100644
index 000000000000..efc390b3f03a
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.8.ebuild,v 1.1 2012/12/03 19:20:25 sping Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ x11-libs/qt-core:4"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${P}-version.patch
+ fi
+ epatch "${FILESDIR}"/${P}-compile.patch
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}